modified on 12 March 2009 at 08:57 ••• 11,861 views

Bulgarian/MikroTik RouterOS Frequently Asked Questions

From MikroTik Wiki

Jump to: navigation, search

See also: Mikrotik_RouterOS_Preguntas_Frecuentes_(español/spanish)

Contents

Какво представлява MikroTik RouterOS™?

Какво прави MikroTik RouterOS™?
MikroTik RouterOS™ е операционна система специализирана за рутиране и маршрутизация която превръща обикновен x86 (AMD/VIA/Transmeta/Intel) базиран Персонален Компютър или MikroTik RouterBOARD™ система в специализиран Рутер.
Мога ли да изпробвам функционалността на MikroTik RouterOS™ преди да закупя Лиценз?
Да, Можете да свалите инсталацията от интернет страницата на MikroTik и да инсталирате собствен MikroTik Рутер. Той ще има пълна функционалност без да въвеждате Лицензионен Ключ за 24 часа общо време на работа. Това време е достатъчно за да тествате Рутера за 3 дни при 8 часа работа на ден, ако изключвате Рутера в края на всеки 8 часов ден.
От къде мога да взема Лицензионен Ключ?
Създайте си акаунт в интернет страницата на MikroTik's (горният десен ъгъл на www.mikrotik.com). Можете да платите и с кредитна карта.
Мога ли да използвам MikroTik Рутер за да реализирам доставка на интернет услуги чрез T1, T3, или друга високоскоростна връзка?
Да, Моете да инсталиране различни мрежови контролери поддържани от MikroTik RouterOS™ и да създадете свой edge router, backbone router, firewall, bandwidth manager, VPN server, wireless access point, HotSpot и още много в една кутия. Моля проверете Спецификацийте и Упътването за поддържаните интерфейси!
Колко бърз ще бъде?
Един Intel базиран персонален компютър е по-бърз от почти всеки стандартен рутер, и дори 100MHz-ов процесор би могъл да бъде доста производителен. Но е желателно да се ползва по-мощен, с цел по добра производителност.
Как този софтуер може да се сравни с Cisco рутер?
Вие можете да правите почти всичко което може и стандартен рутер, но само за част от цената на такъв рутер. Също имате възможността да Надграждате и лесно управление и поддръжка.
От каква операционна система се нуждая за да инсталирам MikroTik RouterOS™?
Не се нуждаете от операционна система. MikroTik RouterOS™ идва със своя собствена операционна система и софтуер. Операционната система е базирана на Linux ядро и е много стабилна. Твърдият Ви диск ще бъте напълно изтрит от инсталатора. Има поддръжка на допълнителни дискове, но е възможно и ползване на един PRIMARY MASTER HDD или FlashDisk, допълнителни твърди дискоове се ползват за WEB proxy cache (опция е и ползването на първия твърд диск за прокси кеш) както и за опцията STОRAGE позволяваща съхранението на базата данни от USER MANAGER и др.
Колко сигурен е рутера след като бъде настроен?
Достъпът до рутера се защитава от име и парола. Могат да се добавят и допълнителни потребители, като се определят специфични правила в потребителските групи. Отдалеченият достъп до рутера може да се ограничи за потребител, IP адрес. Филтъра на Защитната стена е най-лесният начин да защитите Рутера и мрежата си.

"Влизате" в рутера и Пароли

Какво е потребителското име и парола при "влизане" в рутера за първи път?
Потребителското име е 'admin', и няма парола (натиснете 'Enter' клавиша). Можете да смените паролата с командата '/password'.
Как мога да възстановя загубена парола?
Ако сте забравили паролата, тя не може да бъде възстановена. Вие трябва да преинсталирате рутера.
След спиране на електрозахранването MikroTik рутера не се стартира отново
Ако не сте изключили рутера, файловата система не се е "разкачила" правилно. След като се стартира, RouterOS™ ще започне проверка на файловата система. В зависимост от размера на твърдият Ви диск, това може да отнеме няколко минути. Не прекъсвайте проверката на файловата система! Това може да направи инсталацията Ви неизползваема.
Как мога да получа достъп до рутера ако мрежовите интерфейси са изключени?
Можете получите достъп също и локално (използвайки монитор и клавиатура) или чрез серийна конзола.

Лицензионни отношения

Колко MikroTik RouterOS™ инстакаций покрива един Лиценз?
Лицензите са за RouterOS инсталация. Всеки инсталиран рутер трябва да има отделен Лиценз.
Лицензите изтичат ли?
Лицензите никога не изтичат. Рутерът работи завинаги. Но Лицензът има определено време през което може да се обновява - период от време през който можете да обновяватв софтуера до по-нова версия.
Как мога да преинсталирам MikroTik RouterOS™ софтуера без да загубя Лизенза си?
Трябва да използвате CD, Floppies или Netinstall процедура и да инсталирате MikroTik RouterOS™ на диск на който има инсталиран и работещ MikroTik RouterOS™. Лицензионният Ключ се пази с твърдия диск. Не използвайте средства за форматиране и разделяне, те ще изтрият Ключа Ви! Използвайте същите (начални) BIOS настройки за Вашия твърд диск!
Мога ли да използвам Лиценза си за MikroTik RouterOS™ софтуер на различен хардуер?
Да, можете да използвате различен хардуер (дънни платки, мрежови контролери), но трябва да използвате и същия твърд диск. Лицензът се пази на твърдия диск докъто не се форматира или се използва fdisk инструмент. Не е нуно да се преинсталира системата когато я местите на различен хардуер. Когато плащате за Лиценз, моля внимавайте, той неможе да се използва на друг твърд диск освен на този на който е инсталиран.
Прехвърлянето на Лиценз на друг твърд диск струва 10$. Свържете се с поддръжка за да заявите това.
Какво да правя, ако твърдият ми диск с MikroTik RouterOS™ се повреди, и се наложи да инсталирам на друг?
Ако сте платили за Лиценза, то трябва да пишете на support[at]mikrotik.com и да обясните ситуацията. Може да поискаме да ни изпратите повреденото устройство като доказателство за да Ви предоставим заместващ Ключ.
Ако имате безплатен демонстрационен Лиценз, не се предоставят Заместващи Ключове. Моля сдобийте се с друг демонстрационен Лиценз, или купете базов Лиценз.
Повече информация можете да намерите тук - Всичко за Лицензите
Как мога да въведа нов софтуерен Ключ?
Въвеждане на Ключа от Конзола/FTP:
  • въведете прикаченият файл с командата '/system license import' (трябва да качите този файл на FTP сървъра на Рутера)
Въвеждане на Ключа от Конзока/Telnet:
  • използвайте copy/paste за да въведете Ключа в Telnet прозореца (без значение в кое подменю). Уверете се, че сте копирали целия Ключ, включително редовете "--BEGIN MIKROTIK SOFTWARE KEY--" и "--END MIKROTIK SOFTWARE KEY--"
Въвеждане на Ключа от Winbox:
  • използвайте 'system -> license' менюто в Winbox за да Приложите или Въведете Ключа
Допуснал съм грешка при въвеждането на software ID кода когато купувах Ключа. Как мога да коригирам това?
В Потребителският Сървър изберете `work with keys`, след това изберете Вашия сгрешен Ключ, и изберете `fix key`.
Относно въвеждането на Ключове, научете повече на тази страница
Въвеждане на RouterOS Лицензионен Ключ
Всяка друга информация за Лицензионните Клюове може да бъде намерена тук
Всичко за Лицензите

Инсталация

С какъв капацитет може да е твърдият диск на който инсталирам MikroTik RouterOS™?
MikroTik RouterOS™ поддържа дискове по-големи от 8GB (обикновенно до 120GB). Но се уверете, че BIOS-ът на дъното поддържа диска Ви.
Мога ли да стартирам MikroTik RouterOS™ от кой да е твърд диск в системата си?
Да
Има ли поддръжка на много твърди дискове в MikroTik RouterOS™?
Поддържа се втори диск за web cache. Тази функция е въведена в 2.8, по-старите версий не поддържат допълнителни дискове.
Защо инсталацията от CD спира по някое време и не продължава "по пътя напред"?
Инсталацията от CD не работи правилно на някои дънни платки. Пробвайте да рестартирате на компютъра и стартирате инсталацията отново. Ако и това не помогне, опитайте с различен хардуер.

Надграждане

Как мога да инсталирам допълнителни функционални пакети?
Вие трябва да използвате пакети със същата версия (с разширение .npk) като версията на системата. Използвайте командата /system package print за да видите списък с инсталираните пакети. Преди да качите новите пакети проверете свободното дисково пространство на диска на рутера с командата /system resource print. Уверете се, че имате поне 2MB свободно дисково пространство след като качите пакетите!
Качете пакетите на рутера използвайки ftp BINARY режим и стартирайте командата /system reboot за да рестартирате Рутера. Пакетите се инсталират (upgraded) по време на изключването на Рутера. Можете да следите процеса на инсталация на монитор свързан към рутера. След рестартиране, списъка с инсталираните пакети може да бъде видян с командата /system package print.
Как мога да Обновя софтуера?
За да Обновите софтуера, Вие трябва да свалите най-новите пакети (*.npk) от нашият интернет сайт (пакета 'system' плюс тези от които се нуждаете). След това се свържете с рутера чрез FTP и качете новите пакети използвайки Binary transfer mode.
После рестартирайте рутера с командата /system reboot. Повече информация тук: Обновяване на RouterOS
Инсталирах допълнителни функционални пакети, но не откривам допълнителен интерфейс в списъка /interface print.
Вие трябва да имате (закупите) необходимото Ниво на Лиценза, или да инсталирате NPK пакет за този интерфейс (за пример пакет 'wireless').
Ако обновя RouterOS, ще загубя ли настройките си?
Не, настройките се пазят непокътнати при Обновявания на версия от една фамилия. Когато обновявате и фамилията на версийте (за пример, V2.5 до V2.6) Вие можете да загубите настройките на някои функций, които имат генерални промени. За пример когато обновявате от V2.4, Вие трябва първо да обновите до последната версия на 2.4.
От какво свободно дисково пространство се нуждая при обновяване до по-висока версия?
Имате нужда от пространство за системния пакет и всички останали пакети от които имате нужда. След като качите новите версий на пакетите на рутера, Вие трябва да имате поне 2MB свободно дисково пространство. Ако не, не се опитвайте на обновявате! Първо премахнете ненужните пакети, и след това обновете останалите.

Инсталиране на по-стара версия (Downgrading)

Как мога да инсталирам по-стара версия на MikroTik RouterOS™ инсталация?
Можете да понижите версията като преинсталирате RouterOS™ от всяка медия (пример: CD). Лицензът за софтуера се пази с твърдият Ви диск докато той не бъде преразделен или форматиран. Конфигурацията на рутера ще бъде загубена (възможно е да запазите старата конфигурация, но тази опция има непредсказуеми резултати при понижаване на версията и не се препоръчва да я използвате).
Друг начин е да използвате командата /system downgrade. Това работи само ако понижавате до 2.7.20 но не и по-стара. Качете старите пакети на рутера чрез FTP и след това използвайте командата /system downgrade.

TCP/IP Въпроси

Имам две мрежови карти на MikroTik рутера които работят добре. Мога да ping-вам двете мрежи от рутера, но немога да ping-на от едната мрежа през рутера до другата мрежа и до Интернет. Нямам настроена защитна стена.
Това е често срещан проблем. Вие нямате настроено рутиране на главния си Интернет шлюз. След като сте въвели нова мрежа, Вие трябва да 'кажете' за нея на главния си шлюз (Вашият Интернет Доставчик). Трябва да се въведе правило за новата Ви мрежа. Като алтернатива, Вие можете за 'скриете' новата си мрежа чрез masquerading за да получите достъп до Интернет. Моля отделете време за да научите основните настройки, където проблема е обяснен и е дадено решение.
Това е пример как да насреоите masquerade за частната Ви мрежа:
[admin@MikroTik] ip firewall nat> add chain=srcnat action=masquerade out-interface=Public
[admin@MikroTik] ip firewall nat> print
Flags: X - disabled, I - invalid, D - dynamic 
 0   chain=srcnat out-interface=Public action=masquerade 
Как мога да променя TCP порта за telnet или http услуги, ако не искам да използвам портове 23 и 80?
Можете да промените портовете от тук: /ip service
Когато използвам IP адрес/маска от вида 10.1.1.17/24 за моите филтри или queuing правила, те не работят.
Правилата 'не работят', докъто не съвпаднат с пакетите защото са с неправилно описани адрес/маска. Правилната форма ще е:
   10.1.1.0/24 за IP адрес в обсега 10.1.1.0-10.1.1.255, или,
   10.1.1.17/32 само за един IP адрес 10.1.1.17. 
Трябва да настроя DHCP клиент, но няма немю '/ip dhcp-client'.
DHCP функцията не е включена в системния пакет. Вие трябва да инсталирате dhcp пакета. Качете го на рутера и рестартирайте!
Мога ли статично да вързвам IP-та към MAC адреси чрез DHCP?
Да, можете да въвеждате статични 'наеми' в leases списъка на DHCP вървъра. Обаче, DHCP е включено по подразбиране, и е по-добре да използвате PPPoE за оторизация на потребителите и грижа за IP адресите. Така може да поискате потребител а 'влиза' само от определен MAC арес.
Как мога да masquerade две различни подмрежи използвайки два различни външни IP адреса за тях?
Използвайте /ip firewall nat правило с chain=srcnat action=nat, опишете to-src-address стойностите. Това трябва да е един от външните адреси на рутера. Ако използвате action=masquerade, тогава to-src-address не се описва, докъто не е заменен от външният адрес на рутера автоматично.
Немога да посещавам някои сайтова когато използвам PPPoE.
Използвайте /ip firewall mangle за да промените MSS (максимален размер на сегмента) до стойност на MTU по-малка с поне 40 bytes на връзката Ви. За пример, ако имате криптирана PPPoE връзка с MTU=1492, нагласете mangle правило както следва:
/ ip firewall mangle 
add chain=forward protocol=tcp tcp-flags=syn action=change-mss new-mss=1448

Въпроси свързани с Контрол на Трафика

Мога ли да използвам MikroTik като "мост" (bridge) и контрол на трафика в една машина?
Да. Можете да използвате всички разнообразни възможности за queue управление. Нагласете queue на интерфейса където трафика всъщност напуска рутера, когато минава през рутера. Това не е bridge интерфейсът! Queue на bridge интерфейса се отнася само за трафика създаден от тутера.
Мога ли да огранича трафика базирайки се на MAC адреси?
За сваляне:
   1. connection-mark всички пакети от MAC-а на на всеки клиент с различни маркировки
   за всеки клиент използвайки action=passthrough:
   /ip firewall mangle add chain=prerouting src-mac-address=11:11:11:11:11:11 \
   action=mark-connection new-connection-mark=host11 passthrough=yes
   2. Ремаркирайте тези пакети с flow-mark (пак различен flow-marks за всеки connection-marks):
   /ip firewall mangle add chain=prerouting connection-mark=host11 new-packet-mark=host11
   3. Вече можем да използваме тези flow-marks в queue trees.
Това решение ще работи, но то не е много стабилно, защото първият пакет за всяка връзка предназначена за тези клиенти няма да се отчете.
За качване:
   [admin@AP] ip firewall mangle> add chain=prerouting src-mac-address=11:11:11:11:11:11 \
   action=mark-packet new-packet-mark=upload

Wireless Въпроси

Мога ли да bridge wlan интерфейси работещи в station режим?
Не, неможете.