modified on 1 September 2011 at 14:26 ••• 116,358 views

Proxylizer/Getting Started

From MikroTik Wiki

Jump to: navigation, search

Contents

Download

Scripts for install method 1

You can download proxylizer archive here

VMware image download for install method 2

There are 2 ways to download this image file (318 MB) :

Install

All the examples assume that Proxylizer server IP address is 10.1.1.2 and syslog-ng uses port 514 that is its default

The installation includes steps for setting up the following:

Mikrotik router

Web-proxy log export to remote host (Proxylizer server)

To forward logs from Mikrotik Router to Proxylizer server, open RouterOS console and type in the following commands (assuming that Proxylizer Server IP Address is 10.1.1.2):

/system logging action add name=sendToProxylizer target=remote remote=10.1.1.2:514
/system logging add topics=web-proxy,!debug action=sendToProxylizer

Note that logs are sent to port number 514, it must be equal with the port on which Syslog daemon on Proxylizer server is listening.

And then just set up web proxy:

[admin@Proxylizer pruebas] > ip [admin@Proxylizer pruebas] /ip> proxy [admin@Proxylizer pruebas] /ip proxy> print

                enabled: yes
            src-address: 0.0.0.0
                   port: 8080
           parent-proxy: 0.0.0.0
      parent-proxy-port: 0
    cache-administrator: "webmaster"
         max-cache-size: none
          cache-on-disk: no
 max-client-connections: 600
 max-server-connections: 600
         max-fresh-time: 3d
  serialize-connections: no
      always-from-cache: no
         cache-hit-dscp: 4
            cache-drive: system

and redirect the traffic to the web proxy:

[admin@Proxylizer pruebas] /ip firewall nat> print Flags: X - disabled, I - invalid, D - dynamic

0   chain=dstnat action=redirect to-ports=8080 protocol=tcp dst-port=80

Note: remember protect the proxy

Proxylizer server

Install method 1

All the examples assume that web page root directory is "/var/www/proxylizer", web server user is "www-data", Proxylizer server system user is "proxylizer" and .pipe file destination/name is "/home/proxylizer/mysql.pipe".

Required packages

For Ubuntu issue this command to install all required packages:

sudo apt-get install syslog-ng libapache2-mod-php5 php5-cli php-pear php-db php-mail php-mail-mime php-net-smtp php5-mysql mysql-server mysql-client

WARNING : If you have Ubuntu syslog-ng can conflict with ubuntu-minimal package! You can remove this package.

Web page scripts

Download proxylizer archive. Create directory and extract it in web page root directory:

sudo tar -xvzf  proxylizer.tar.gz -C /var/www/
Permissions for directories

Change ownership of web page root directory for web server user:

 chown proxylizer:www-data /var/www/proxylizer -R 

Set write permissions to web page root directory for web server user:

 chmod g+w /var/www/proxylizer -R

Set permissions to execute 3 shell script files for web server user group:

cd /var/www/proxylizer
chmod ug+x checkwebproxy.sh mail_send.php webproxylogtomysql.php
Syslog daemon

Change syslog-ng config to receive logs from Mikrotik router and put them into mysql.pipe file. Open /etc/syslog-ng/syslog-ng.conf and add these lines next to "#destinations" :

destination d_mysql {
pipe("/home/proxylizer/mysql.pipe"
template("$HOST $YEAR-$MONTH-$DAY $HOUR:$MIN:$SEC $MSG\n") template-escape(yes));
};
log { source(net); destination(d_mysql); };

And this line next to "#sources":

source net { udp(); };

Create pipe file:

mkfifo /home/proxylizer/mysql.pipe

Set destination of .pipe file in /var/www/proxylizer/webproxylogtomysql.php. At the beginning of the file you must change variable value in the line:

$MYSQL_PIPE = "/home/proxylizer/mysql.pipe";

restart syslog:

/etc/init.d/syslog-ng restart

Note: The last version of Syslog-NG don't project the string "web-proxy,account" to the pipe, so the $rawlog[] depending variables from the php script are bad setted. If you use syslog-ng 3.1.x or more please use this line to avoid problem:

destination d_mysql {
pipe("/home/proxylizer/mysql.pipe"
template("$HOST $YEAR-$MONTH-$DAY $HOUR:$MIN:$SEC web-proxy,account $MSG\n") template-escape(yes));
};
log { source(net); destination(d_mysql); };
MySQL user for proxylizer database

Default user name for mysql database is root with no password. But we recomend to change it for security reasons.
To create new database proxylizerdb and user proxylizer with password passwd connect to mysql server, using command:

mysql -u root

and issue the following commands in mysql frontend:

CREATE DATABASE proxylizerdb;
GRANT ALL PRIVILEGES ON proxylizerdb.* TO proxylizer@localhost IDENTIFIED BY "password" WITH GRANT OPTION;
FLUSH PRIVILEGES;

If you use mysql user other than root without password, connect to mysql server, using

mysql -u usrname -p

and you will be asked to enter the mysql user's password.

Scheduled scripts for forwarding records from syslog to MySQL and report generation

Create directory for script logs and set permesions:

sudo mkdir /var/log/proxylizer
sudo chown proxylizer:proxylizer /var/log/proxylizer
sudo chmod u+w /var/log/proxylizer

If you want to write logs in different directory you must edit bash script "checkwebproxy.sh" and change "/var/log/proxylizer" to preferred directory.

Put two scripts in cron sheduler. First create crontab file for web server system user:

nano /home/proxylizer/proxylizercrontab

and copy these lines:

SHELL=/bin/sh
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
* *     * * *           /var/www/proxylizer/mail_send.php >> /var/log/proxylizer/mail_send_log.log
* *     * * *           /var/www/proxylizer/checkwebproxy.sh >> /var/log/proxylizer/checkwebproxy.log &

Set scheduler tasks from this file:

crontab /home/proxylizer/proxylizercrontab
Database and web page access configuration

When all previous settings is set. Open web browser and point it to proxylizer server. First page must be like this :

Setup.png

  • DB type - for now Proxylizer supports only MySQL, in future PostgreSQL, Interbase and other data bases will be added;
  • DB host - by default "localhost", i.e,. database is located on the Proxylizer server;
  • DB name - by default "proxylizer", must be equal with the one set here;
  • DB username and password - as you have set here;
  • Webpage username and password - as you prefer;

Setup page is shown always when the config file config_constants.php is not found in the Proxylizer root directory. On successful setup the configuration is written to this file. Configuration file contains database access and web page access parameters, no report or IP user configuration is included.

Mail sending configuration

To start receive reports to email, go to IP users page and add user with email address, then to Config page and configure Mail server access (any SMTP account needed).

Install method 2

It is posible to download already installed linux(debian) and proxylizer VMware virtual machine image and use proxylizer on any platform supported by VMware.

  • Download VMware player.
  • Download archived VMware proxylizer image
  • Network settings:
    • if not in DHCP network open /etc/network/interfaces and change address, netmask, gateway etc.
  • Passwords and usernames :
    • root password "rootroot";
    • username - "proxylizer", password - "rootroot";
    • mysql: root password - "proxylizer"; proxylizer data base username - "proxylizer", password - "password";
    • webpage: username- "proxylizer", password - "rootroot";

First report

First read documentation of web interface here. If you wan't to just check users web usage - create once report for date interval you are interested in and after a few moments report will be ready. If you wan't to see all users visited domains - create domain report, but remember it is only possible to get report for date interval which is already passed. For example if you want data for today report will be generated only tomorrow.