Russian/FAQ

From MikroTik Wiki
Jump to: navigation, search

FAQ по RouterOS

Что такое MikroTik RouterOS™?

Для чего предназначена MikroTik RouterOS™
MikroTik RouterOS™ - это операционная система и набор программ для обеспечения маршрутизации, которая превращает обычный Intel PC или MikroTik RouterBOARD™ в выделенный программный маршрутизатор.
Можно ли протестировать функциональность MikroTik RouterOS™ перед покупкой лицензии?
Да, вы можете загрузить дистирбутив со страницы MikroTik и установить свой собственный маршрутизатор MikroTik. Маршрутизатор имеет полноценную функциональность в течение 24 часов без необходимости использования лицензионного ключа. Этого времени достаточно, чтобы протестировать маршрутизатор в течение 3-х дней по 8 часов каждый, если вы будете останавливать маршрутизатор в конце каждого 8-и часового дня тестирования.
Где я могу получить лицензионный ключ?
Создайте аккаунт на странице MikroTik (верхний правый угол на странице по адресу www.mikrotik.com). Вы можете использовать кредитную карту для оплаты ключа.
Могу ли я использовать маршрутизатор MikroTik для соединения с провайдером через каналы T1/T3 или другие высокоскоростные соединения?
Да, вы можете установить различные сетевые карты, поддерживаемые MikroTik RouterOS™, и создать свой пограничный маршрутизатор (edge router), магистральный маршрутизатор (backbone router), брандмауэр, средство управления трафиком, сервер VPN, беспроводную точку доступа, HotSpot и много чего еще. Пожалуйста, прочитайте спецификации и руководство
Насколько быстро это решение?
Intel PC быстрее, чем почти любой из проприетарных маршрутизаторов, и даже вычислительной мощности 100MHz CPU в данном случае достаточно.
Как это программное обеспечение сравнимо с маршрутизатором Cisco?
Вы можете сделать практически все, что делает проприетарный маршрутизатор, за очень небольшую цену и получить гибкость в обновлении, легкость в управлении и обслуживании.
Какая операционная система мне нужна, чтобы установить MikroTik RouterOS™?
Операционная система не нужна. MikroTik RouterOS™ - это собственно операционная система плюс программное обеспечение. ОС основана на ядре Linux и очень стабильна. Во время процесса инсталляции с вашего жёсткого диска будет всё удалено. Поддерживается использование IDE- и SATA-дисков, возможна установка на USB-Flash.
Насколько обеспечена безопасность маршрутизатора после установки?
Доступ к маршрутизатору защищён с помощью имени пользователя и пароля. Могут быть созданы дополнительные пользователи, специфические права могут быть присвоены группам пользователей. Удалённый доступ к маршрутизатору может быть ограничен конкретным пользователем, IP адресом. Фильтрация с помощью файервола - самый лёгкий способ защитить ваш маршрутизатор и сеть.

Вход в систему и пароли

Какое имя пользователя и пароль используются для входа в систему при первом старте?
Имя пользователя 'admin', без пароля (нажмите клавишу 'Enter'). Вы можете изменить пароль с помощью команды '/password'.
Как я могу восстановить утерянный пароль?
Если вы забыли пароль, его невозможно восстановить. Вы должны переустановить маршрутизатор.
После внезапного выключения питания маршрутизатор не стартует
Если вы не выключили маршрутизатор стандартно, то файловая система не будет размонтирована правильно. При старте, MikroTik RouterOS™ запустит проверку файловой системы. В зависимости от размера жёсткого диска, проверка может занять несколько минут. Не прерывайте проверку файловой системы! Это приведет к нестабильности всей системы.
Как я могу получить доступ к маршрутизатору, если сетевой интерфейс был отключён?
Вы можете получить доступ к маршрутизатору либо локально (используя монитор и клавиатуру), или через последовательный порт (serial консоль).


Лицензирование

Сколько инсталляций MikroTik RouterOS™ приходится на одну лицензию?
Лицензия даётся на одну инсталляцию RouterOS. Каждый установленный маршрутизатор нуждается в отдельной лицензии.
Имеет ли лицензия срок действия?
Лицензия не имеет срока действия. Маршрутизатор работает вечно. Но лицензия имеет ограничение на версию обновления - максимальную версию ОС, которую вы можете использовать с данной лицензией.
Как я могу переустановить MikroTik RouterOS™ без потери моей лицензии?
Вы должны установить MikroTik RouterOS™ на ваш жёсткий диск (используя CD, флоппи или сетевую установку), на котором находится нетронутая предыдущая установка MikroTik RouterOS™. Не форматируйте жёсткий диск, не используйте программы изменения разделов - это приведет к уничтожению ключа! Используйте те же (исходные) установки в БИОС для вашего жёсткого диска!
Могу ли я использовать мою MikroTik RouterOS™ лицензию на другом оборудовании?
Да, вы можете использовать другое оборудование (материнскую плату, сетевую карту), но вы должны использовать тот же жёсткий диск. Лицензия распознаётся по жёсткому диску, до тех пор пока не применено форматирование или программа fdisk. Переустанавливать систему не является требованием, когда вы меняете оборудование. Когда вы платите за лицензию, пожалуйста, имейте в виду, что она не может быть использована на другом жёстком диске, отличном от того, на котором уже установлена.
Перемещение лицензии на другой жёсткий диск стоит 10$. Чтобы сделать это, свяжитесь со службой поддержки.
Что мне делать, если мой жёсткий диск с MikroTik RouterOS™ разрушен и мне надо инсталлировать на другой?
Если вы покупали лицензию, вы должны написать на support[at]mikrotik.com и описать ситуацию. Мы можем попросить вас прислать нерабочий диск нам как доказательство, перед тем как перевыпустить лицензионный ключ.
Если у вас бесплатная демонстрационная лицензия, замена ключа вам не может быть выдана. Пожалуйста, получите другую демонстрационную лицензию или приобретите базовую лицензию.
Больше информации находится в разделе Всё о лицензиях (англ.)
Как я могу ввести новый ключ?
Ввод нового ключа через Console/FTP:
  • импортировать прикреплённый файл с помощью команды /system license import (вы должны загрузить этот файл на FTP сервер маршрутизатора)
Ввод нового ключа через Console/Telnet:
  • используйте copy/paste, чтобы ввести ключ в окно Telnet (не имеет значения какое подменю). Проверьте, что скопировали ключ полностью, включая строки "--BEGIN MIKROTIK SOFTWARE KEY--" и "--END MIKROTIK SOFTWARE KEY--"
Ввод ключа через Winbox:
  • используйте 'system -> license' меню в Winbox чтобы вставить или импортировать ключ
Я опечатался при вводе ID программного обеспечения, когда я покупал ключ. Как я могу исправить это?
На сервере учётных записей (Account Server) выберите 'work with keys' ('работа с ключами'), затем выберите ваш ключ с опечаткой и нажмите `Edit key` ('править ключ')
Дополнительную информацию о введении ключей смотрите в разделе Ввод лицензионных ключей RouterOS (англ.)
Любая другая информация о лицензионных ключах - в разделе Всё о лицензиях (англ.)


Инсталляция

Насколько большие жёсткие диски я могу использовать с MikroTik RouterOS™?
MikroTik RouterOS™ поддерживает диски от 8 Гб (обычно до 120 Гб). Удостоверьтесь, что БИОС материнской платы поддерживает такие большие диски.
Могу я стартовать MikroTik RouterOS™ с любого жёсткого диска на моём компьютере?
Да
Поддерживает ли MikroTik RouterOS™ работу с несколькими жёсткими дисками?
В версии 3.15 была добавлена поддержка дополнительных хранилищ (Storages) для записи данных (основных и резервных копий) UserManager, The Dude и Web-Proxy. Планируется дальнейшее развитие идеи (например, в поддержке хранения логов).
Почему при инсталляции с CD установка останавливается и не идёт дальше?
Инсталляция с CD на некоторых материнских платах не работает должным образом. Попробуйте перезагрузить компьютер и запустить инсталляцию снова. Если это не помогает, попробуйте другое оборудование.


Обновление ПО

Как я могу установить дополнительные пакеты?
Вы должны использовать ту же версию пакетов (расширение .npk), как и системный пакет. Используйте команду /system package print, чтобы вывести список установленных пакетов. Проверьте размер свободного места на диске перед загрузкой новых пакетов с помощью команды /system resource print. Удостоверьтесь, что после загрузки новых пакетов на жёстком диске свободно по крайней мере 2 Мб.
Загрузите пакеты на маршрутизатор используя FTP в режиме BINARY, затем перезагрузите его командой /system reboot.
Пакеты инсталлируются, пока маршрутизатор завершает работу. Вы можете наблюдать процесс установки пакетов на мониторе. После перезагрузки список установленных пакетов можно просмотреть командой /system package print.
Как я могу произвести обновление?
Чтобы обновить ПО, вы должны загрузить последние пакеты (*.npk) с сайта MikroTik (пакет 'system' плюс те, которые вам нужны). Затем, соединитесь с маршрутизатором через FTP и загрузите новые пакеты на него, используя режим BINARY.
Затем перезагрузите маршрутизатор командой /system reboot. Больше информации находится здесь: Обновление RouterOS (англ.)
Я инсталлировал дополнительный пакет, но соответствующий интерфейс не виден в списке после выполнения команды /interface print.
Вы должны получить (приобрести) лицензию требуемого уровня или инсталлировать NPK пакет для этого интерфейса (например, пакет 'wireless').
Если я обновлю RouterOS, потеряю ли я мою конфигурацию?
Нет, конфигурация будет сохранена при обновлении в пределах версии одного семейства. Если обновляется семейство версии (например, V2.5 до V2.6), вы можете потерять конфигурацию некоторых особенностей, которые претерпевают большие изменения. Например, если вы обновляетесь с версии V2.4, вы должны сначала обновиться на последнюю версию семейства 2.4.
Сколько свободного места на диске мне нужно, чтобы обновиться на более новую версию?
Вам нужно свободное пространство для системного пакета и для дополнительных пакетов, которые вы обновляете. После загрузки пакетов более новой версии на маршрутизатор вы должны иметь по-крайней мере 2 Мб свободного пространства. Если это не так, то не пытайтесь делать обновление! Деинсталлируйте сначала ненужные пакеты и затем обновляйте оставшиеся.


Откат на предыдущие версии ПО

Как я могу понизить версию установленной MikroTik RouterOS™?
Вы можете понизить версию путем переустановки RouterOS™ с любого носителя. Лицензия останется работоспособной на жёстком диске до тех пор, пока не произведено форматирование или изменение разделов. Конфигурация маршрутизатора будет утеряна (возможно сохранить старую конфигурацию, но эта возможность даёт непредсказуемые результаты при понижении версии и не рекомендуется использовать этот способ).
Другой способ - использовать команду /system package downgrade. Это возможно только при понижени до версии не ниже 2.7.20. Загрузите пакеты более старой версии на маршрутизатор через FTP и затем используйте команду /system package downgrade.


Вопросы, касающиеся TCP/IP
В моём маршрутизаторе MikroTik две сетевые карты и они работают правильно. Я пингую обе сети с маршрутизатора но не могу пинговать из одной сети в другую через маршрутизатор и в интернет. Файервол не установлен.
Это типичная проблема, вы не имеете установленного роутинга на вашем главном интернет-шлюзе. Когда вы добавляете новую сеть, вы должны 'сказать' об этом вашему главному шлюзу (вашему провайдеру службы интернета - ISP). Маршрут должен быть добавлен для вашей новой сети. Альтернативно, вы можете 'спрятать' вашу новую сеть в смысле маскарадинга, чтобы получить доступ в интернет. Пожалуйста, ознакомьтесь с Руководством по Первичной Установке (Basic Setup Guide), там эта проблема описана и дано её решение.
Ниже дан пример маскарадинга вашей частной сети (private LAN):
[admin@MikroTik] ip firewall nat> add chain=srcnat action=masquerade out-interface=Public
[admin@MikroTik] ip firewall nat> print
Flags: X - disabled, I - invalid, D - dynamic 
 0   chain=srcnat out-interface=Public action=masquerade 
Как я могу изменить номер TCP порта для telnet или http, если я не хочу использовать порты 23 и 80, соответственно?
Вы можете изменить номера портов с помощью службы /ip service.
Если я использую IP адрес/маску в виде 10.1.1.17/24 для правил фильтрации или очереди (queuing), то они не работают.
Правила 'не работают', если они не видят пакеты из-за некорректно указанных адреса/маски. Корректная форма приведена ниже:
   10.1.1.0/24 для IP-адресов из диапазона 10.1.1.0-10.1.1.255
  или
   10.1.1.17/32 для единственного IP-адреса 10.1.1.17. 
Мне нужно установить клиент DHCP, но я не нахожу пункта меню '/ip dhcp-client'.
Системный пакет, предоставлюящий DHCP-клиент, не установлен или не включен. Вы должны установить пакет dhcp. Загрузите его на маршрутизатор и перезагрузитесь!
Могу я статически привязать IP адрес к MAC адресу через DHCP?
Да, вы можете добавить статическую аренду к списку аренды DHCP сервера. Однако, DHCP по-умолчанию небезопасен, и лучше использовать PPPoE для аутентификации пользователя и выдачи IP адресов. Также, вы можете потребовать от пользователя входить с определённого MAC адреса.
Как я могу скрыть две различные подсети, используя для них два различных внешних IP адреса?
Используйте правило /ip firewall nat с chain=srcnat action=nat, указав to-src-address как значение аргумента. Это должен быть один из внешних адресов маршрутизатора. Если вы используете action=masquerade, то to-src-address не будет принято в расчёт, так как это подставлено внешним адресом маршрутизатора автоматически.
Я не могу попасть на некоторые сайты, если я использую PPPoE.
Используйте /ip firewall mangle чтобы изменить MSS (maximum segment size - максимальный размер сегмента) на величину, меньшую на 40 байт, чем MTU вашего соединения. Например, если вы имеете шифрованый PPPoE линк с MTU=1492, установите mangle правило следующим образом:
/ ip firewall mangle 
add chain=forward protocol=tcp tcp-flags=syn action=change-mss new-mss=1448


Вопросы управления трафиком

Могу ли я использовать MikroTik как мост и ограничитель трафика (traffic shaper) на одном компьютере?
Да. Вы можете использовать все обширные возможности управления очередью. Не забудьте включить обработку пакетов, проходящих через мост, правилами файрвола: /interface bridge settings set use-ip-firewall=yes (по умолчанию эта возможность выключена).
Могу ли я ограничить трафик, основываясь на MAC адресе?
Для входящего трафика (download):
1. Отметить меткой соединения все пакеты от MAC каждого клиента разными метками используя action=passthrough:
   /ip firewall mangle add chain=prerouting src-mac-address=11:11:11:11:11:11 \
   action=mark-connection new-connection-mark=host11 passthrough=yes
2. Отметить эти пакеты с метки потока (снова различные метки потоков для каждой метки соединения):
   /ip firewall mangle add chain=prerouting connection-mark=host11 new-packet-mark=host11
3. Теперь можем использовать метки потока в дереве очередей:
В то время как это решение должно функционировать, оно имеет существенный недостаток, поскольку первый пакет каждого соединения, предназначенного этим клиентам, не будет принят во внимание.
Для исходящего трафика (upload):
   [admin@AP] ip firewall mangle> add chain=prerouting src-mac-address=11:11:11:11:11:11 \
   action=mark-packet new-packet-mark=upload

Вопросы беспроводной связи

Могу я сделать мост на wlan интерфейсе, работающем в режиме station?
Нет, это сделать нельзя. Необходимо использовать режим pseudobridge.