modified on 30 April 2010 at 22:42 ••• 16,283 views

Silent boot

From MikroTik Wiki

Jump to: navigation, search
Spanish Version: [SilentBoot]
Version.png

Applies to RouterOS: v4

Contents

Summary

This feature allows to suppress all output from RouterBOARD over serial port and suppress beeping on RouterOS boot. Very useful if you have some custom devices attached to it and they get confused from output when router boots up or is operational.

Requirements

To have this feature you have to have corresponding RouterOS version or newer and correct RouterBOOT version or newer running on RouterBOARD hardware.

Icon-warn.png

Warning: Supported RouterBOARD devices does not include mipsle architecture boards (RB500 series ,RB100 series and Crossroads)


Icon-note.png

Note: Sound suppression is available since RouterOS 4.7 and RouterBOOT 2.26. This setting does not suppress :beep command


Icon-note.png

Note: Console output suppression is available since RouterOS 4.4 and RouterBOOT 2.25


Configuration

Suppress console boot output

To disable console output you have disable console on serial output, that is enabled on all RouterBOARD devices by default. That can be achieved this menu:

 /system console

by default you will see this output in the menu:

 [admin@172.16.23.190] /system console> print detail 
  Flags: X - disabled, U - used, F - free 
 0 F port=serial0 term="vt102"

Then just disable that entry there.


Other part of configuration that will work only on RouterOS 4.4 or newer and RouterBOOT 2.25 or newer To suppress boot messages, you have two different ways to do same thing:

RouterOS configuration

 /system routerboard settings set baud-rate=off

From boot menu before RouterOS boots

  • When RouterBOARD starts to boot press key as specified by message

Default message looks like that:

 Press any key within 2 seconds to enter setup
  • Select option:
  s - serial console
  • Select option 9 (value: off) in serial console baud rate menu
 Select baud rate for serial console:
  * 1 - 115200                                                                 
     2 - 57600                                                                  
     3 - 38400                                                                  
     4 - 19200                                                                  
     5 - 9600                                                                   
     6 - 4800                                                                   
     7 - 2400                                                                   
     8 - 1200                                                                   
     9 - off                                                                    
  your choice: 

To disable this configuration

  • boot with reset button pressed, that will load backup bios with different settings
  • enable console output from running RouterOS

Suppress boot sounds

These settings can be changed in two different ways that result in same effect and settings are changed in both places if changed in either of them.

RouterOS configuration

To enable boot sound suppression user have to change setting as follows:

  • to disable boot sounds use
/system routerboard settings set silent-boot=yes 
  • to enable boot sounds use
/system routerboard settings set silent-boot=no

RouterBOOT configuration

When RouterBOARD is booting up, enter in RouterBOOT settings and choose option n - silent boot

What do you want to configure?                                                   
d - boot delay                                                                
k - boot key                                                                  
s - serial console                                                            
n - silent boot                                                              
o - boot device                                                               
u - cpu mode                                                                 
f - cpu frequency                                                             
r - reset booter configuration                                                 
e - format nand                                                               
g - upgrade firmware                                                         
i - board info                                                                
p - boot protocol                                                            
b - booter options                                                            
t - call debug code                                                           
l - erase license                                                             
x - exit setup                         
your choice: n - silent boot                             

turn silent boot on or off by choosing corresponding value.

Silent boot:                                                                     
0 - off                                                                     
* 1 - on                                                                      
your choice: