modified on 14 April 2014 at 08:32 ••• 229,880 views

SwOS

From MikroTik Wiki

Jump to: navigation, search

Contents

Summary

SwOS is an operating system designed specifically for administration of MikroTik Switch products.

SwOS is configurable from your web browser. It gives you all the basic functionality for a managed switch, plus more: Allows to manage port-to-port forwarding, broadcast storm control, apply MAC filter, configure VLANs, mirror traffic, apply bandwidth limitation and even adjust some MAC and IP header fields.

Icon-warn.png

Warning: Each RouterBoard switch series have their own firmware which cannot be installed on other series models!


  • RB250GS supports SwOS v1.0 and newer.
  • RB260GS supports SwOS v1.7 and newer.
  • RB260GSP supports SwOS v1.11 and newer.


Connecting to the Switch

Open your web browser and enter IP address of your Switch (192.168.88.1 by default) and login screen will appear.

Swos login.png

SwOS default IP address: 192.168.88.1, user name: admin and there is no password.

Icon-note.png

Note: MikroTik neighbor discovery protocol tools can be used to discover IP address of Mikrotik Switch. Manual:IP/Neighbor_discovery


Interface Overview

SwOS interface menu consists of 10 tabs: Link, Forwarding, Statistics, VLAN, VLANs, Static Hosts, Hosts, SNMP, ACL and System.

Description of buttons in SwOS configuration tool:

  • Append - add new item to the end of the list
  • Apply All - applies current configuration changes
  • Cut - removes item from the list
  • Clear - resets properties of the item
  • Discard Changes - removes unsaved configuration
  • Insert - add new item to the list (places it before current item)
  • Sort - sort VLAN table by VLAN-IDs; sort host table by MAC addresses

  • Change Password - changes password of the switch
  • Logout - logout from current Switch
  • Reboot - reboot the switch
  • Reset Configuration - reset configuration back to factory defaults
  • Choose File - browse for upgrade or backup file
  • Upgrade - upgrade firmware of the Switch
  • Restore Backup - restore Switch using selected backup file
  • Save Backup - generate and download backup file from the Switch

System Tab

Swos system.png

System Tab performs the following functions:

  • General information about Switch
  • Switch management
  • Configuration reset
  • Backup and restore configuration
  • Firmware upgrade

Property Description
IP AddressIP address of the Switch
IdentityName of the Switch (for Mikrotik neighbor discovery protocol)
Allow FromIP address from which the service is accessible. Default value is '0.0.0.0/0' - any address
Allow From PortsList of switch ports from which the service is accessible
Allow From VLANVLAN ID with which the service is accessible (VLAN Mode on ingress port must be other than disabled in order to connect)
Mikrotik Discovery ProtocolEnable or disable Mikrotik neighbor discovery protocol
WatchdogEnable or disable system watchdog. It will reset CPU of the switch in case of fault condition
MAC AddressMAC address of the Switch (Read-only)
VersionFirmware version of the Switch
UptimeCurrent Switch uptime


Icon-note.png

Note: SwOS uses a simple algorithm to ensure TCP/IP communication - it just replies to the same IP and MAC address packet came from. This way there is no need for Default Gateway on the device itself.


Firmware Upgrade

Firmware can be upgraded/downgraded by selecting firmware file and pressing upgrade button. Switch will reboot automatically after successful upgrade.

Icon-note.png

Note: Manual power cycle is necessary 5 seconds after upgrade button is pressed if you are upgrading from SwOS v1.0


Link Tab

Swos link.png

Link Tab allows you to:

  • Configure Ethernet ports
  • Monitor status of Ethernet ports

Property Description
EnabledEnable or disable port
Link StatusCurrent link status (Read-only)
Auto NegotiationEnable or disable auto negotiation
SpeedSpecify speed setting of the port (requires auto negotiation to be disabled to specify)
Full DuplexSpecify duplex mode of the port (requires auto negotiation to be disabled to specify)
Flow control Enable or disable flow control

Forwarding Tab

Swos forwarding.png

Forwarding Tab provides advanced forwarding options among switch ports, port locking, port mirroring, bandwidth limit and broadcast storm control features.

Property Description
ForwardingForwarding table - allows or restricts traffic flow between specific ports
Port Lock
  • Port Lock - Enable or disable MAC address learning on this port
  • Lock On First - Enable or disable MAC address learning on this port (MAC address from the first recieved packet will still be learnt)
Port Mirroring
  • Mirror Ingress - Whether traffic entering this port must be copied and forwarded to mirroring target port
  • Mirror Egress - Whether traffic leaving this port must be copied and forwarded to mirroring target port
  • Mirror To - Mirroring target port
Bandwidth Limit
  • Ingress Rate - Limit traffic entering this port (bps) (only supported on RB250GS)
  • Egress Rate - Limit traffic leaving this port (bps)
Broadcast Storm Control
  • Storm Rate - Limit the number of broadcast packets transmitted by an interface (only supported on RB250GS)
  • Include Unicast - Include unicast packets without an entry in host table in Storm Rate limitation (only supported on RB250GS)

Statistics Tab

Swos statistics.png

Provides detailed information about received and transmitted packets.

Packet Flow

Packet processing through RB250GS is described here: Atheros8316 packet flow diagram

VLAN Tab

Swos vlan.png

VLAN configuration for Switch ports.


Property Description
VLAN Mode

VLAN mode for ingress port:

  • disabled - VLAN table is not used. Switch ignores VLAN tag part of tagged packets
  • optional - Handle packets with VLAN tag ID that is not present in VLAN table just like packets without VLAN tag
  • enabled - Drop packets with VLAN tag ID that is not present in VLAN table. Packets without VLAN tag are treat as tagged packets with Default VLAN ID
  • strict - Same as enable, but also checks VLAN support for inbound interface (drop packets with VLAN tag ID and ingress port that are not present in VLAN table)
VLAN ReceiveDefines the type of allowed packets on ingress port: any / only tagged / only untagged (only supported on RB260GS)
Default VLAN IDSwitch will treat untagged ingress packets as they are tagged with this VLAN ID. VLAN tag itself will be added only if there is VLAN Header = add if missing specified on egress port
Force VLAN IDWhether to apply Default VLAN ID to incoming packets with VLAN tag
VLAN Header
  • leave as is - if VLAN header is present it remains unchanged
  • always strip - if VLAN header is present it is removed from the packet
  • add if missing - if VLAN header is not present it is added to the packet (VLAN ID will be Default VLAN ID of ingress port)
Icon-note.png

Note: VLAN modes enabled and strict require VLAN ID 1 in VLANs table to allow access of untagged traffic to switch itself.


Example

VLANs Tab

VLAN tables specifies certain forwarding rules for packets that have specific 802.1q tag. Basically the table contains entries that map specific VLAN tag IDs to a group of one or more ports. Packets with VLAN tags leave switch through one or more ports that are set in corresponding table entry. VLAN table works together with destination MAC lookup to determine egress ports. VLAN table supports up to 4096 entries.

RB250GS VLANs tab

Alt text
RB250GS VLANs tab
Property Description
VLAN IDVLAN ID of the packet
PortsPorts the packet should be mapped to

RB260GS VLANs tab

Alt text
RB260GS VLANs tab
Property Description
VLAN IDVLAN ID of the packet
PortsEach port has individual VLAN header options for each VLAN ID. Depending on VLAN mode if lookup is done in this table, egress action of packets is processed by this option. Egress option from VLAN tab is ignored.

Hosts Tab

Swos hosts.png

This table represents dynamically learnt MAC address to port mapping entries. When Switch receives a packet from certain port, it adds the packets source MAC address X and port it received the packet from to host table, so when a packet comes in with destination MAC address X it knows to which port it should forward the packet. If the destination MAC address is not present in host table then it forwards the packet to all ports in the group. Dynamic entries take about 5 minutes to time out.

Icon-note.png

Note: RB250GS and RB260GS support 2048 host table entries.


Property Description
MACMAC address (Read-only)
PortsPorts the packet should be forwarded to (Read-only)

Static Hosts Tab

Swos static hosts.png

Static host table entries. Static entries will take over dynamic if dynamic entry with same mac-address already exists. Also by adding a static entry you get access to some more functionality.

Property Description
MACMAC address
PortsPorts the packet should be forwarded to
MirrorPacket can be cloned and sent to mirror-target port
DropPacket with certain MAC address coming from certain ports can be dropped

ACL Tab

Swos acl.png

An access control list (ACL) rule table is very powerful tool allowing wire speed packet filtering, forwarding and VLAN tagging based on L2,L3 protocol header field conditions. SwOS allow you to implement limited number of access control list rules (32 simple rules (only L2 conditions are used); 16 rules where both L2 and L3 conditions are used; or 8 advanced rules where all L2,L3 and L4 conditions are used).

Each rule contains a conditions part and an action part.

Conditions part parameters

Property Description
FromPort that packet came in from
MAC SrcSource MAC address and mask
MAC DstDestination MAC address and mask
EthertypeProtocol encapsulated in the payload of an Ethernet Frame
VLAN

VLAN header presence:

  • any
  • present
  • not present
VLAN IDVLAN tag ID
PriorityPriority in VLAN tag
IP Src (IP/netmask:port)Source IP address, netmask and L4 port number
IP Dst (IP/netmask:port)Destination IP address, netmask and L4 port number
ProtocolIP protocol
DSCPIP DSCP field

Action part parameters

Property Description
Redirect ToWhether to force new destination ports (If Redirect To is enabled and no ports specified in Redirect To Ports, packet will be dropped )
Redirect To PortsDestination ports for
MirrorClones packet and sends it to mirror-target port
RateLimits bandwidth (bps) (only supported on RB260GS)
Set VLAN IDChanges the VLAN tag ID, if VLAN tag is present
PriorityChanges the VLAN tag priority bits, if VLAN tag is present


SNMP Tab

Swos snmp.png

SNMP Tab consists of settings to monitor the Switch remotely.

Available SNMP data:

  • System information
  • System uptime
  • Port status
  • Interface statistics
Property Description
EnabledEnable or disable SNMP service
CommunitySNMP community name
Contact InfoContact information for the NMS
LocationLocation information for the NMS

Reinstall SwOS firmware

It is possible to upload and install SwOS firmware using BOOTP. This example shows how to reinstall SwOS using RouterOS.

Icon-warn.png

Warning: Each RouterBoard switch series have their own firmware which cannot be installed on other series models!


  • RB250GS supports SwOS v1.0 and newer.
  • RB260GS supports SwOS v1.7 and newer.
  • RB260GSP supports SwOS v1.11 and newer.


  • Configure IP address and DHCP server with BOOTP enabled on the installation router.
/ip address
add address=192.168.88.254/24 interface=ether1
/ip pool
add name=dhcp_pool1 ranges=192.168.88.1
/ip dhcp-server
add address-pool=dhcp_pool1 bootp-support=dynamic interface=ether1 disabled=no
/ip dhcp-server network
add address=192.168.88.0/24 gateway=192.168.88.254
  • Upload new SwOS firmware file to the router filesystem.
[admin@MikroTik] /file> print 
 # NAME             TYPE             SIZE                 CREATION-TIME       
 0 swos-1.2.lzb     .lzb file        38142                sep/02/2010 08:40:17
  • Configure TFTP server.
/ip tftp
add allow=yes disabled=no ip-addresses=192.168.88.1 read-only=yes \
    real-filename=swos-1.2.lzb
  • Hold the RESET button of the switch when starting it.
  • After few seconds ACT LED will start blinking. Wait till ACT LED blinks twice as fast and release RESET button.
  • Make ethernet connection between the switch and ethernet port you configured DHCP server on. After few seconds new firmware should be successfully uploaded and installed.

Reset

There are two ways to reset the device to defaults:

Jumper reset hole

Located on the bottom of case, behind one of the rubber feet of all SwOS devices – resets SwOS software to defaults. Must short circuit the metallic sides of the hole (with a screwdriver, for example) and boot the device. Hold screwdriver in place until SwOS configuration is cleared.

Reset button

The only button on the SwOS device. It has two functions:

  • Hold this button during boot time until LED light starts flashing, release the button to reset SwOS configuration (same result as with reset hole)
  • Hold this button during boot time longer, until LED starts to bling twice as fast, and then release it to make the device wait for TFTP firmware upgrade