Basic Installation of RouterOS

From MikroTik Wiki
Jump to: navigation, search

Installation


This example shows how to install and configure Mikrotik RoterOS.

First download new RouterOS form here [1]

Then write ISO image file to CD and put in CD-ROM Drive and turn on.

Bi1.gif

Press "a" key for select all and then press "i"

Answer "n" to first question and "y" to second

Bi2.gif after installation remove cd from cdrom and press "Enter"

after rebooting type "admin" as login and no password.

Add IP address

When mikrotik prompt is ready assign IP address to NIC:

/ip address
 add address=10.0.0.1/24 interface=ether1
 add address=192.168.0.1/24 interface=ether2

ether1 = WAN ( Connected To Your Router ) Alone -- ether2= LAN ( Connected To Your Switch (hub) With Clients -- now add default gateway IP address:

/ip route
 add gateway=10.0.0.2

10.0.0.1,192.168.0.1 and 10.0.0.2 is sample data and you should use your IP for setting

if use your IP now you can ping internet

ping 4.2.2.4
4.2.2.4 64 byte ping: ttl=242 time=255 ms
4.2.2.4 64 byte ping: ttl=242 time=243 ms
4.2.2.4 64 byte ping: ttl=242 time=247 ms
4.2.2.4 64 byte ping: ttl=242 time=243 ms
4 packets transmitted, 4 packets received, 0% packet loss
round-trip min/avg/max = 243/247.0/255 ms

ok.

NAT

NAT will use until client with invalid IP connect to internet, so we must run NAT on mikrotik and set client IP in range of 192.168.0.2 and set client gateway to 192.168.0.1(Secend NIC of mikrotik)

/ip firewall nat
 add chain=srcnat action=masquerade out-interface=ether1

this will be route all traffic to interface 1 that have an valid IP so will be NAT and go to internet