Dial-up

From MikroTik Wiki
Jump to: navigation, search

How to Connect your Office Network Using Dial-up Modem

If you have a dial-up internet connectivity using dial-up modem, and want to have a connection to the Internet for your small office network. For that, you have to install MikroTik router between the dial-up modem and your office network.

This example is useful in remote places, where internet is only available thru basic dial-up connectivity using dial-up modem.

  • Before configuring, attach you dial-up modem to mikrotik serial console.
  • Assign IP address
/ip address
add address=192.168.1.1/24 interface=ether1 comment=”Office network”
  • Configure PPP dialout connection
/interface ppp-client
add port=serial0 user=ashish password=ashish123 phone=172233 add-default-route=yes

[admin@mikrotik] interface ppp-client> print
Flags: X - disabled, R - running
 0 X  name="ppp-out1" max-mtu=1500 max-mru=1500 port=serial0 user="ashish"
         password="ashish123" profile=default phone="172233" dial-command="ATDT"
         modem-init="" null-modem=no dial-on-demand=no add-default-route=yes
         use-peer-dns=no allow=pap,chap,mschap1,mschap2
  • By default, It is Disabled, You need to enable it
[admin@mikrotik] interface ppp-client> enable 0
  • You can monitor the connectivity status
[admin@mikrotik] interface ppp-client> monitor 0
  • Finally, masquerade your office network
/ip firewall nat
add chain=srcnat src-address=192.168.1.0/24 out-interface= ppp-out1 action= masquerade

Now you office network is connected with Internet using dial-up modem. You can also configure VPN after getting connected with internet.