Dual Setup with OSPF

From MikroTik Wiki
Jump to: navigation, search

In this setup we will be connecting a PTP configuration using a Dual Setup and OSPF (Open Shortest Path First).
The requirements for this set up is to have a board that supports at least 02 radios.
If you would like to double the bandwidth and redundancy, take a look at this Tutorial with Dual Radios.

The advantages for this setup are:

  • Full Duplex
  • Automatic Failover
  • No delay of packets. The same set up utilizing N-Streme-Dual can cause delay, which can be a problem if you're dealing with VoIP or applications that requires maximum response.
  • This set up can make use of two radios at each end, so the availability becomes even more robust in case of a radio failure.

Full-duplex.gif

Icon-warn.png

Warning: In illustration above, both remote networks are from the same subnet. Such setup is not valid, each remote network must be from the different subnet. In configuration below on Router B 192.168.0.2/24 is replaced with 192.168.1.1/24


Configuring the Radio A:

/ip address add address=192.168.0.1/24 interface=ether1
/ip address add address=192.168.10.1/24 interface=wlan1
/ip address add address=192.168.20.1/24 interface=wlan2
/routing ospf network add network=192.168.10.0/24 area=backbone1
/routing ospf network add network=192.168.20.0/24 area=backbone1
/routing ospf interface add interface=wlan1 cost=100

Configuring the Radio B:

/ip address add address=192.168.1.1/24 interface=ether1
/ip address add address=192.168.10.2/24 interface=wlan1
/ip address add address=192.168.20.2/24 interface=wlan2
/routing ospf network add network=192.168.10.0/24 area=backbone1
/routing ospf network add network=192.168.20.0/24 area=backbone1
/routing ospf interface add interface=wlan2 cost=100

This set will cause the incoming traffic to use wlan1 on A and wlan2 on B.
This also will use any available path to get to the other side (Failover with OSPF).