Manual:EoMPLS vs Cisco

From MikroTik Wiki
Jump to: navigation, search

Summary

This article describes the basic setup of Point-to-Point EoMPLS with Cisco routers. In this example IOS 15.1 was used, configuration in older versions may differ.


Configuration

Consider network setup as ilustrated below:

EoMPLS-cisco.png

We will be setting up the layer 2 connection between the CE and PE routers as well as the MPLS and EoMPLS between PE routers. The layer 2 link between the CE and PE routers will be an Ethernet circuit.

Set up IP connectivity, OSPF and LDP

CE1:
/ip address add address=192.168.111.1/24 interface=ether1
CE2:
/ip address add address=192.168.111.2/24 interface=ether2


PE1 (RouterOS):
/interface bridge add name=loopback0

/ip address
add address=10.255.111.244/32 interface=loopback0
add address=10.5.111.244/24 interface=ether1

/mpls ldp
set enabled=yes lsr-id=10.255.111.244 transport-address=10.255.111.244

/mpls ldp interface
add interface=ether1

/routing ospf network
add area=backbone network=10.255.111.111/32
add area=backbone network=10.5.111.0/24

PE2 (IOS):
mpls label protocol ldp
!
interface Loopback0
 ip address 10.255.111.111 255.255.255.255
!
interface GigabitEthernet5/1
 ip address 10.5.111.111 255.255.255.0
 mpls ip
 mpls label protocol ldp
!
router ospf 1
 redistribute connected
 network 10.5.111.0 0.0.0.255 area 0
 network 10.255.111.111 0.0.0.0 area 0
!

Configure EoMPLS tunnel

PE1 (RouterOS):
/interface bridge
add name=vpn

/interface vpls
add cisco-style=yes cisco-style-id=111 disabled=no l2mtu=1500 name=cisco-eompls \
    remote-peer=10.255.111.111 use-control-word=yes

/interface bridge port
add interface=ether2 bridge=vpn
add interface=cisco-eompls bridge=vpn


PE2 (IOS):
pseudowire-class l2vpn
 encapsulation mpls
 control-word
!
interface GigabitEthernet5/2
 no ip address
 xconnect 10.255.111.244 111 pw-class l2vpn
  mtu 1500
!


Adjust MTUs

Because Ethernet over MPLS does not allow packets to be fragmented and reassembled on Cisco routers, ensure that the maximum transmission unit (MTU) of all intermediate links between endpoints is sufficient to carry the largest possible Layer 2 frame.

PE1 (RouterOS):
/mpls interface
set [find interface=all ] mpls-mtu=1526


PE2 (IOS):
interface GigabitEthernet5/1
 mtu 1526
 ip mtu 1500
 mpls mtu 1526
!

Verify Tunnel Operation

PE1 (RouterOS):
[admin@RouterOS] /interface vpls> monitor 0
       remote-label: 19
        local-label: 21
      remote-status: 
          transport: 10.255.111.111/32
  transport-nexthop: 10.5.111.111
     imposed-labels: 19



PE2 (IOS):
C7606#show mpls l2transport vc

Local intf     Local circuit              Dest address    VC ID      Status    
-------------  -------------------------- --------------- ---------- ----------
Gi5/2          Ethernet                   10.255.111.244  111        UP   

For more detailed output:

C7606#show mpls l2transport vc detail 
Local interface: Gi5/2 up, line protocol up, Ethernet up
  Destination address: 10.255.111.244, VC ID: 111, VC status: up
    Output interface: Gi5/1, imposed label stack {21}
    Preferred path: not configured  
    Default path: active
    Next hop: 10.5.111.244
  Create time: 2d21h, last status change time: 01:36:12
  Signaling protocol: LDP, peer 10.255.111.244:0 up
    Targeted Hello: 10.255.111.111(LDP Id) -> 10.255.111.244, LDP is UP
    Status TLV support (local/remote)   : enabled/not supported
      LDP route watch                   : enabled
      Label/status state machine        : established, LruRru
      Last local dataplane   status rcvd: No fault
      Last local SSS circuit status rcvd: No fault
      Last local SSS circuit status sent: No fault
      Last local  LDP TLV    status sent: No fault
      Last remote LDP TLV    status rcvd: Not sent
      Last remote LDP ADJ    status rcvd: No fault
    MPLS VC labels: local 19, remote 21 
    Group ID: local 0, remote 0
    MTU: local 1500, remote 1500
    Remote interface description: 
  Sequencing: receive disabled, send disabled
  Control Word: On
  VC statistics:
    transit packet totals: receive 6073, send 5394
    transit byte totals:   receive 1309806, send 758021
    transit packet drops:  receive 0, seq error 0, send 18

See Also