Manual:IP/Cloud

From MikroTik Wiki
Jump to: navigation, search
Version.png

Applies to RouterOS: v6.14 +

Summary

Since RouterOS v6.14 MikroTik offers multiple services for your RouterBOARD devices that are connected to the Internet. These services are meant to ease the inconveniences when configuring, setting up, controlling, maintaining or monitoring your device. More detailed list of available services that IP/Cloud can provide can be found below.

Icon-note.png

Note: Since RouterOS v6.27 "ip cloud enabled" is renamed to "ip cloud ddns-enabled" this may require some changes in your scripts if you are using this feature in a script.


Services

Icon-note.png

Note: Since RouterOS v6.43 your device will use cloud2.mikrotik.com to communicate with the MikroTik's Cloud server. Older versions will use cloud.mikrotik.com to communicate with the MikroTik's Cloud server.


Icon-warn.png

Warning: Be aware that if router has multiple public IP addresses and/or multiple internet gateways, the exact IP used for the communicating with the MikroTik's Cloud server may not be as expected!


Icon-note.png

Note: IP/Cloud requires a working license on Cloud Hosted Router (CHR).


DDNS

DDNS or Dynamic DNS is a service that updates the IPv4 address for A records and the IPv6 address for AAAA records periodically. Such a service is very useful when your ISP has provided a dynamic IP address that changes periodically, but you always need an address that you can use to connect to your device remotely. Below you can find operation details that are relevant to the IP/Cloud's DDNS service:

  • Checks for outgoing IP address change: every 60 seconds
  • Waits for the MikroTik's Cloud server's response: 15 seconds
  • DDNS record TTL: 60 seconds
  • Sends encrypted packets to cloud.mikrotik.com or cloud2.mikrotik.com using UDP/15252 port

Since RouterOS v6.43 if your device is able to reach cloud2.mikrotik.com using IPv6, then a DNS AAAA record is going to be created for your public IPv6 address. If your device is only able to reach cloud2.mikrotik.com using IPv4, then only a DNS A record is going to be created for your public IPv4 address.

To enable the DDNS service:

[admin@MikroTik] /ip cloud set ddns-enabled=yes
[admin@MikroTik] /ip cloud print
         ddns-enabled: yes
          update-time: yes
       public-address: 159.148.147.196
  public-address-ipv6: 2a02:610:7501:1000::2
             dns-name: 529c0491d41c.sn.mynetname.net
               status: updated
Icon-note.png

Note: When the service is enable, a DNS name will be stored on the MikroTik's Cloud server permanently and this DNS name will resolve to the last IP that your IP has sent to the MikroTik's Cloud server.


To disable the DDNS service:

/ip cloud set ddns-enabled=no
Icon-note.png

Note: As soon as you disable the service, your device sends a command to the MikroTik's Cloud server to remove the stored DNS name.


To manually trigger a DNS update:

[admin@MikroTik] > /ip cloud force-update
Icon-note.png

Note: To actually connect to the device using the DNS name provided by cloud server, user must configure router's firewall to permit such access from the WAN port. (Default MikroTik configuration does not permit access to services such as WebFig, WinBox etc. from WAN port)


Update time

Correct time on a device is important, it cause issues with the system's logs, break HTTPS connectivity to the device, tunnel connectivity and other issues. To have your system's clock updated, you can use NTP or SNTP, though it requires you to specify an IP address for the NTP Server. In most cases NTP/SNTP is not required in order to simply have a correct time set on the device, for simplicity you can use the IP Cloud's update time service. Below you can find operation details that are relevant to the IP/Cloud's update time service:

  • Approximate time (accuracy of several seconds, depends on UDP packet latency)
  • Updates time after a reboot and during every DDNS update (when router's WAN IP address changes or after the force-update command is used)
  • Sends encrypted packets to cloud.mikrotik.com or cloud2.mikrotik.com using UDP/15252 port
  • Detects time-zone depending on the router's public IP address and our commercial database

To enable the time update service:

[admin@MikroTik] > /ip cloud set update-time=yes 

To enable automatic time zone detection:

[admin@MikroTik] > /system clock set time-zone-autodetect=yes 
Icon-note.png

Note: If /ip cloud update-time is set to auto, then device's clock will be updated with MikroTik's Cloud server time (if no NTP or SNTP client is enabled).


Backup

Since RouterOS v6.44beta9 it is possible to store your device's backup on MikroTik's Cloud server. The backup service allows you to upload an encrypted backup file, download it and apply the backup file to your device as long as your device is able to reach MikroTik's Cloud server. Below you can find operation details that are relevant to the IP/Cloud's backup service:

  • 1 free backup slot for each device
  • Allowed backup size: 50MB
  • Sends encrypted packets to cloud2.mikrotik.com using UDP/15252 and TCP/15252 port

To create a new backup and upload it the MikroTik's Cloud server:

/system backup cloud upload-file action=create-and-upload password=test123!!!
[admin@MikroTik] > /system backup cloud print 
 0 name="cloud-20180921-162649" size=13.2KiB ros-version="6.44beta9" date=sep/21/2018 16:26:49 status="ok" secret-download-key="AbCdEfGhIjKlM1234567890" 
Icon-note.png

Note: The create-and-upload action command will create a new system's backup file,encrypt the backup file with AES using the provided password and upload it. For upload action command the password property has no effect since the upload action command uploads only already created system's backup files.


To download the uploaded backup file and save it to device's memory:

[admin@MikroTik] > /system backup cloud download-file action=download number=0
### OR
[admin@MikroTik] > /system backup cloud download-file action=download secret-download-key=AbCdEfGhIjKlM1234567890
Icon-warn.png

Warning: The secret-download-key is a unique identifier that can be used to download your encrypted backup to your other devices. Since you can download your encrypted backup from any location and any device by using the secret-download-key, then you should try to keep this identifier a secret. The downloaded backup is still encrypted using AES, nevertheless make sure you are using a strong password!


To remove the uploaded backup:

/system backup cloud remove-file number=0

To upload an existing backup file (created previously):

[admin@MikroTik] > /system backup save encryption=aes-sha256 name=old_backup password=test123!!!
[admin@MikroTik] > /system backup cloud upload-file action=upload src-file=old_backup.backup
[admin@MikroTik] > /system backup cloud print 
 0 name="cloud-20180921-164044" size=13.2KiB ros-version="6.44beta9" date=sep/21/2018 16:40:44 status="ok" secret-download-key="AbCdEfGhIjKlM1234567890"
Icon-note.png

Note: Make sure that the backup was encrypted using AES, otherwise the IP/Cloud will reject the backup upload. Since there is only 1 free backup slot per device, then you need to remove the existing backup before uploading a new one.


Icon-warn.png

Warning: When importing a backup all MAC addresses are set to the MAC addresses that the device was using. This is useful when you are replacing a device that has failed, but this might not be desired when applying the same backup on multiple devices since it will set the same MAC addresses on multiple devices, which can cause connectivity issues. You can always use the reset-mac-address command on each interface to set the original MAC address back.


Properties

Sub-menu: /ip cloud


Property Description
ddns-enabled (yes | no; Default: no) If set to yes, then the device will send an encrypted message to the MikroTik's Cloud server. The server will then decrypt the message and verify that the sender is an authentic MikroTik device. If all is OK, then the MikroTik's Cloud server will create a DDNS record for this device and send a response to the device. Every minute the IP/Cloud service on the router will check if WAN IP address matches the one sent to MikroTik's Cloud server and will send encrypted update to cloud server if IP address changes.
update-time (yes | no; Default: yes) If set to yes then router clock will be set to time, provided by cloud server IF there is no NTP or SNTP client enabled. If set to no, then IP/Cloud service will never update the device's clock. If update-time is set to yes, Clock will be updated even when ddns-enabled is set to no.
public-address (read-only: address) Shows device's IPv4 address that was sent to cloud server and assigned to DNS name (see dns-name). This field is visible only after at least one ddns-request was successfully completed.
public-address-ivp6 (read-only: address) Shows device's IPv6 address that was sent to cloud server and assigned to DNS name (see dns-name). This field is visible only after at least one ddns-request was successfully completed.
warning (read-only: string) Shows a warning message if IP address sent by the device differs from the IP address in UDP packet header as visible by the MikroTik's Cloud server. Typically this happens if the device is behind NAT. Example: "DDNS server received request from IP 123.123.123.123 but your local IP was 192.168.88.23; DDNS service might not work"
dns-name (read-only: name) Shows DNS name assigned to the rdevice. Name consists of 12 character serial number appended by .sn.mynetname.net. This field is visible only after at least one ddns-request is successfully completed.
status (read-only: string) Contains text string that describes current dns-service state. The messages are self explanatory
  • updating...
  • updated
  • Error: no Internet connection
  • Error: request timed out
  • Error: REJECTED. Contact MikroTik support
  • Error: internal error - should not happen. One possible cause is if router runs out of memory


Advanced

Sub-menu: /ip cloud advanced


Property Description
use-local-address (yes | no; Default: no) By default, the DNS name will be assigned to the detected public address (from the UDP packet header). If you wish to send your "local" or "internal" IP address, then set this to yes

Cloud backup

Sub-menu: /system backup cloud


Blow you can find commands and properties that are relevant to the specific command, other properties will not have any effect.

  • download-file
Property Description
action (download) Downloads an uploaded backup file from MikroTik's Cloud server.
number (integer) Specifies the backup slot on the MikroTik's Cloud server, the free backup slot is always going to be in the 0th slot.
secret-download-key (string) Unique identifier that can be used to download your uploaded backup file. When downloading the uploaded backup file you do not have to be using the same device, from which the backup was uploaded from. Useful when deploying a backup on a new device.


  • remove-file
Property Description
number (integer) Deletes the backup file in the specified backup slot, the free backup slot is always going to be in the 0th slot.


  • upload-file
Property Description
action (create-and-upload) Uploads a backup file to the MikroTik's Cloud server.
  • create-and-upload - creates a new backup file with the specified password and uploads it
  • upload - uploads a created system's backup file.
name (string) Specifies the backup's name that will show up in the uploaded backups list. This is NOT the source backup's name, this name is only used for visual representation.
src-file (file) Backup's file name to upload that was created using /system backup. This property only has effect when action is set to upload.
password (string) Create, encrypt and upload a backup file with the specified password. This property only has effect when action is set to create-and-upload.

[ Top | Back to Content ]