User Manager/QA/How to make MAC authentication

From MikroTik Wiki
Jump to: navigation, search

Let's consider configuration scenario, when we need HotSpot users MAC authentication trough User Manager. HotSpot MAC authentication method allows to authenticate clients as soon as they appear in the hosts list, using client's MAC address as username. We assume that User Manager already provides AAA for HotSpot router.

Configuration required on HotSpot server router:

 /ip hotspot profile set hsprof1 login-by=mac use-radius=yes

Command enables MAC authentication for the particular profile and forces to use RADIUS for AAA. Note, first local HotSpot database is consulted, then User Manager database.

User Manager configuration (for each mac-address):

 /too user-manager user add username=XX:XX:XX:XX:XX:XX subscriber=MikroTik

We add user information belonging to the particular subscriber, it allows HotSpot user with MAC-address XX:XX:XX:XX:XX:XX to authenticate in HotSpot without prompting login/password.