Manual:Interface/VRRP

From MikroTik Wiki
< Manual:Interface(Redirected from VRRP)
Jump to navigation Jump to search
Version.png

Applies to RouterOS: v3, v4, v5


Summary

Sub-menu level: /interface vrrp
Standards: RFC 5798, RFC 3768


This chapter describes the Virtual Router Redundancy Protocol (VRRP) support in RouterOS.

Mostly on larger LANs dynamic routing protocols ( OSPF or RIP) are used, however there are number of factors that may make undesirable to use dynamic routing protocols. One alternative is to use static routing, but if statically configured first hop fails, then host will not be able to communicate with other hosts.

In IPv6 networks, hosts learn about routers by receiving Router Advertisements used by Neighbor Discovery (ND) protocol. ND already has built in mechanism to determine unreachable routers. However it can take up to 38seconds to detect unreachable router. It is possible to change parameters and make detection faster, but it will increase overhead of ND traffic especially if there are a lot of hosts. VRRP allows to detect unreachable router within 3seconds without additional traffic overhead.

Virtual Router Redundancy Protocol (VRRP) provides a solution by combining number of routers into logical group called Virtual Router (VR). VRRP implementation in RouterOS is compliant to VRRPv2 RFC 3768 and VRRPv3 RFC 5798.

Icon-note.png

Note: According to RFC authentication is deprecated for VRRP v3


Protocol Overview

Simple VRRP example

The purpose of the VRRP is to communicate to all VRRP routers associated with the Virtual Router ID and support router redundancy through a prioritized election process among them.

All messaging is done by IPv4 or IPv6 multicast packets using protocol 112 (VRRP). Destination address of IPv4 packet is 224.0.0.18 and for IPv6 it is FF02:0:0:0:0:0:0:12. Source address of the packet is always the primary IP address of an interface from which the packet is being sent. In IPv6 networks source address is link-local address of an interface.

These packets are always sent with TTL=255 and are not forwarded by the router. If for any reason router receives a packet with lower TTL, packet is discarded.

Each VR node has a single assigned MAC address. This MAC address is used as a source for all periodic messages sent by Master.

Virtual Router is defined by VRID and mapped set of IPv4 or IPv6 addresses. Master router is said to be the owner of mapped IPv4/IPv6 addresses. There are no limits to use the same VRID for IPv4 and IPv6, however these will be two different Virtual Routers.

Only Master router is sending periodic Advertisement messages to minimize the traffic. Backup will try to preempt the Master only if it has the higher priority and preemption is not prohibited.

All VRRP routers belonging to the same VR must be configured with the same advertisement interval. If interval does not match router will discard received advertisement packet.

Icon-warn.png

Warning: In case VRRP is used with Reverse Path Filtering, then it is recommended that rp-filter is set to loose, otherwise the VRRP interface might not be reachable.


Virtual Router (VR)

A Virtual Router (VR) consists of one Owner router and one or more backup routers belonging to the same network.

VR includes:

  • VRID configured on each VRRP router
  • the same virtual IP on each router
  • Owner and Backup configured on each router. On a given VR there can be only one Owner.


Virtual MAC address

VRRP automatically assigns MAC address to VRRP interface based on standard MAC prefix for VRRP packets and VRID number. First five octets are 00:00:5E:00:01 and last octet is configured VRID. For example, Virtual Routers VRID is 49, then virtual MAC address will be 00:00:5E:00:01:31.

Icon-note.png

Note: Virtual mac address can not be manually set or edited.



Owner

VRRP without Owner

An Owner router for a VR is default Master router and operates as the Owner for all subnets included in the VR. As mentioned before priority on an owner router must be the highest value (255). In example network R1 is an Owner. It's priority is set to 255 and virtual IP is the same as real IP (owns the virtual IP address).

All Virtual Router members can be configured so that virtual IP is not the same as physical IP. Such Virtual address can be called floating or pure virtual IP address.

Advantage of this setup is flexibility given to the administrator. Since the virtual IP address is not the real address of any one of the participant routers, the administrator can change these physical routers or their addresses without any need to reconfigure the virtual router itself.

Icon-note.png

Note: RouterOS can not be configured as Owner. Pure virtual IP configuration is the only valid configuration unless non-RouterOS device is set as owner.



Master

Master router in a VR operates as the physical gateway for the network for which it is configured. Selection of the Master is controlled by priority value. Master state describes behavior of Master router. In example network R1 is the Master router. When R1 is no longer available R2 becomes master.

Backup

VR must contain at least one Backup router. Backup router must be configured with the same virtual IP as Master for that VR. Default priority for Backup routers is 100. When current master router is no longer available, backup router with highest priority will become current master. Every time when router with higher priority becomes available it is switched to master. Sometimes this behavior is not necessary. To override it preemption mode should be disabled.


Virtual Address

Virtual IP associated with VR must be identical and set on all VR nodes. On Owner router Virtual IP must be the same as real IP. For example on Owner router real IP and virtual IP is 192.168.1.1, on Backup router virtual IP is 192.168.1.1, but real IP is 192.168.1.2. All virtual and real addresses should be from the same network.

If the Master of VR is associated with multiple IP addresses, then Backup routers belonging to the same VR must also be associated with the same set of virtual IP addresses. If virtual address on the Master is not also on Backup a misconfiguration exists and VRRP advertisement packets will be discarded.

Icon-note.png

Note: It is not recommended to set up Mikrotik router as an Owner router. VRRP address and real IP address should not be the same.



In IPv6 networks first address is always link-local address associated to VR. If multiple IPv6 addresses are configured, then they are added in advertisement packet after the link-local address.


IPv4 ARP

The Master for a given VR responds to ARP requests with the VR's assigned MAC address. Virtual MAC address is also used as the source MAC address for advertisement packets sent by the Master. To ARP requests for non-virtual IP addresses router responds with the system MAC address. Backup routers are not responding to ARP requests for Virtual IPs.

IPv6 ND

As you may know, in IPv6 networks, the Neighbor Discovery protocol is used instead of ARP. When a router becomes the Master, an unsolicited ND Neighbor Advertisement with the Router Flag is sent for each IPv6 address associated with the virtual router.

VRRP state machine

VRRP state transition flow

As you can see from diagram, each VRRP node can be in one of three states:

  • Init state
  • Backup state
  • Master state


Init state

The purpose of this state is to wait for a Startup event. When this event is received, then following actions are taken:

  • if priority is 255,
  • * for IPv4 send advertisement packet and broadcast ARP requests
  • * for IPv6 send an unsolicited ND Neighbor Advertisement for each IPv6 address associated with the virtual router and set target address to link-local address associated with VR.
  • * transit to MASTER state;
  • else transit to BACKUP state.


Backup state

When in backup state,

  • in IPv4 networks, node is not responding to ARP requests and is not forwarding traffic for the IP associated with the VR.
  • in IPv6 networks, node is not responding to ND Neighbor Solicitation messages and is not sending ND Router Advertisement messages for VR associated IPv6 addresses.

Routers main task is to receive advertisement packets and check if master node is available.

Backup router will transit itself to master state in two cases:

  • If priority in advertisement packet is 0;
  • When Preemption_Mode is set to yes and Priority in the ADVERTISEMENT is lower than the local Priority

After transition to Master state node is:

  • in IPv4 broadcasts gratuitous ARP request;
  • in IPv6 sends an unsolicited ND Neighbor Advertisement for every associated IPv6 address.

In other cases advertisement packets will be discarded. When shutdown event is received, transit to Init state.

Icon-note.png

Note: Preemption mode is ignored if Owner router becomes available.


Master state

When MASTER state is set, node functions as a forwarding router for IPv4/IPv6 addresses associated with the VR.

In IPv4 networks Master node responds to ARP requests for the IPv4 address associated with the VR. In IPv6 networks Master node:

  • responds to ND Neighbor Solicitation message for the associated IPv6 address;
  • sends ND Router Advertisements for the associated IPv6 addresses.


If advertisement packet is received by master node:

  • If priority is 0, send advertisement immediately;
  • If priority in advertisement packet is greater than nodes priority then transit to backup state
  • If priority in advertisement packet is equal to nodes priority and primary IP Address of the sender is greater than the local primary IP Address, then transit to backup state
  • Ignore advertisement in other cases

When shutdown event is received, send advertisement packet with priority=0 and transit to Init state.

Configuring VRRP

IPv4

Setting up Virtual Router is quite easy, only two actions are required - create vrrp interface and set Virtual Routers IP address.

For example, add vrrp to ether1 and set VRs address to 192.168.1.1

/interface vrrp add name=vrrp1 interface=ether1
/ip address add address=192.168.1.1/32 interface=vrrp1

Notice that only 'interface' parameter was specified when adding vrrp. It is the only parameter required to be set manually, other parameters if not specified will be set to their defaults: vrid=1, priority=100 and authentication=none.

Icon-note.png

Note: address on VRRP interface must have /32 netmask if address configured on VRRP is from the same subnet as on router's any other interface.


Before VRRP can operate correctly correct IP address is required on ether1. In this example it is 192.168.1.2/24

VRRP Examples section contains several configuration examples.


IPv6

To make VRRP work in IPv6 networks, several additional options must be enabled - v3 support is required and protocol type should be set to IPv6:

/interface vrrp add name=vrrp1 interface=ether1 version=3 v3-protocol=ipv6

Now when VRRP interface is set, we can add global address and enable ND advertisement:

/ipv6 address add address=FEC0:0:0:FFFF::1/64 advertise=yes interface=vrrp1

No additional address configuration is required as it is in IPv4 case. IPv6 uses link-local addresses to communicate between nodes.

Property reference

Sub-menu: /interface vrrp


Property Description
arp (disabled | enabled | proxy-arp | reply-only; Default: enabled) ARP resolution protocol mode
authentication (ah | none | simple; Default: none) Authentication method to use for VRRP advertisement packets.
  • none - should be used only in low security networks (e.g., two VRRP nodes on LAN).
  • ah - IP Authentication Header. This algorithm provides strong protection against configuration errors, replay attacks and packet corruption/modification. Recommended when there is limited control over the administration of nodes on a LAN.
  • simple - uses clear text password. Protects against accidental misconfiguration of routers on local network.
interface (string; Default: ) Interface name on which VRRP instance will be running
interval (time [10ms..4m15s]; Default: 1s) VRRP update interval in seconds. Defines how often master sends advertisement packets.
mtu (integer; Default: 1500) Layer3 MTU size
name (string; Default: ) VRRP interface name
on-backup (string; Default: ) Script to execute when the node is switched to backup state
on-master (string; Default: ) Script to execute when the node is switched to master state
password (string; Default: ) Password required for authentication. Can be ignored if authentication is not used.
preemption-mode (yes | no; Default: yes) Whether master node always has the priority. When set to 'no' backup node will not be elected to be a master until the current master fails, even if the backup node has higher priority than the current master. This setting is ignored if Owner router becomes available
priority (integer: 1..254; Default: 100) Priority of VRRP node used in Master election algorithm. Higher number means higher priority. '255' is reserved to Router that owns VR IP and '0' is reserved for Master router to indicate that it is releasing responsibility.
v3-protocol (ipv4 | ipv6; Default: ipv4) Protocol that will be used by VRRPv3. Valid only if version is 3
version (integer [2, 3]; Default: 3) Which VRRP version to use.
vrid (integer: 1..255; Default: 1) Virtual Router identifier. Each Virtual router must have unique id number


There are two ways to add scripts to on-backup and on-master


See more


[ Top | Back to Content ]