Difference between revisions of "Supported Hardware"

From MikroTik Wiki
Jump to: navigation, search
m (3G cards)
m (3G cards)
Line 732: Line 732:
 
|v4.6
 
|v4.6
 
|C-MOTECH Co, FW301DOWMX, QUALCOMM Patch 33504--Tested with v4.11 on RB433UAH, Data CH=1 Info CH=3 Phone #777 for Sprint in US
 
|C-MOTECH Co, FW301DOWMX, QUALCOMM Patch 33504--Tested with v4.11 on RB433UAH, Data CH=1 Info CH=3 Phone #777 for Sprint in US
 +
|USB
 
|----
 
|----
 
|Sprint U300/300U 4G wireless card [http://support.sprint.com/support/device/Sprint/3G4G_USB_Modem_U300-franklin_u300]
 
|Sprint U300/300U 4G wireless card [http://support.sprint.com/support/device/Sprint/3G4G_USB_Modem_U300-franklin_u300]

Revision as of 16:18, 8 September 2011

This page should be edited by the user community to reflect their tested hardware and version used.

See also: Device driver list in manual

Motherboards

Vendor Model ROS version Result
Asrock Intel 82801G chipset 3.0-3.14 Bad performance, locks up under heavy load, supports multi cpu, PATA not supported, integrated ethernet not recognized. Maybe it's just Asrock bad motherboard don't know if the problem is in intel 82801G chipset tested on 2 motherboards, never tested on 2.9.x
ASUS  P5B-Deluxe (Intel P965, 3xPCI, 3xPCI-E) 3.13 Works fine on Intel Core 2 Duo E6400. Not supported PATA controller. Both integrated Gigabit NIC (Marvell Yukon 88E8056 & 88E8001) works fine but only at 100Mbps.
ASUS P5B-V (Intel P965, 3xPCI, 4xPCI-E) 3.13 Works fine on Intel Dual Core E2180. Not supported PATA controller. Integrated Gigabit NIC Marvell Yukon 88E8001 works fine but only at 100Mbps. Winbox via MAC = problem, disconnects after 3 seconds. Winbox via IP no problem.
ASUS P5KC (Intel P35, 3x PCI, 3xPCI-E) 3.10 Not supported PATA controller (JMicron JMB363), ROS can boot from USB flash drive; internal ethernet not recognized.
ASUS P5GC-MX/1333 (2x PCI) 3.7 Works great for pentium dual-core e2160, hdd pata and sata, 1,5gb ram dual channel mode, except the attansic l2 ethernet onboard card is not recognized.
ASUS P5GC (6xPCI) 2.9.39 Ethernet recognized but not working
ASUS P7P55D PRO 4.5 Works ok, PATA controller (JMicron JM363) and internal Ethernet successfully recognized.
ASUS P6T SE 4.0 RouterOS boots and works with SATA disk set to 'IDE compatibility mode'.
ASUS A7V133-C 3.0 beta 7 Works fine
ASUS A7V600-X 3.25 Works fine
EPoX EP-4VKMI 3.16 - 3.24 Works fine.
EPoX 8RDA+ 3.6 Work fine including integrated ethernet
Intel D815EGEW 2.9.x Excellent performance under 2.9. Not tested under v3. Onboard Ethernet Works perfectly.
Intel DG950 2.9.42 Ethernet not recognized
Intel  D945GCCRL 2.9.43 & 3.0 beta 5 Ethernet & DoM not recognized
Intel  D945GCLF2 3.23 4 core's, 2gb ram, 32gb ssd, no problems.
Intel D945GCPE 3.0 beta 9 Work fine including integrated ethernet
Intel  D945GCNL 3.11 Works fine but integrated ethernet (just disable) goes up and down on reboots multi-cpu= yes. shared IRQ for PCI devices, decrease nic performace.
Intel D945GNT 2.9.45 Works fine
Intel DP55WG 4.6 multi-cpu smp works great, onboard NIC not supported by RouterOS 4.6 yet though, must use pci/pci express nics
Intel DQ965GFEKR (D41676) 3.7, 3.4 Works fine on 3.7/3.4 if multi-cpu=no, BUT 3.5-3.7 fail to boot with E4600 processor and multi-cpu=yes
Intel  D845GVSRL 3.7, 3.1, 2.9 Very Stable, used for 4 years
Intel DG965SWH 3.0 beta 9 Works fine, but only with SATA not IDE
Intel DG33FB 3.7 Works fine, Ethernet but not working (IRQ 9), set in BIOS Security/XD Tegnology to disable
Intel S3210SHLC 4.2 Boot from USB stick. Work fine for my PPPoE server. Up to 1300 users with summary 200Mbit traffic.
Intel D945GZT-M 3.0rc4 Works fine
Chaintech  AADF950 3.0 beta 5 Works fine
Abit KT7E 3.0 beta 7 Works fine
ECS  nForce3-A 3.6 Work fine including integrated ethernet
ECS P4M800PRO-M478 2.9.43 No Apparent Problems, Disabled any unneeded devices in the BIOS
Abit BE6 2.9.43 Works
VIA EPIA-MII12000 2.9.42 Locks up under heavy load across wireless
Supermicro 5015M-MR 2.9.28 Motherboard is PDSMi w dual core
Supermicro PDSBM-LN2+ 2.9.51 & 3.16 http://forum.mikrotik.com/viewtopic.php?f=1&t=28184
Supermicro PDSMi-LN4+ 2.9.51, 3.13, 3.20 Very stable even with dual-cores enabled.
Gigabyte GA-41M-ES2L 3.28 Works fine; CPU Intel Core2 Dual 2.7GHz; 2XRB44GV
Gigabyte GA-6BXS 2.9.43 Works fine
Gigabyte  GA-8I848P-G 3.6 Work fine including integrated ethernet
Gigabyte GA-8ST667 rev. 3.0 3.13 Works fine; CPU Intel Celeron 2,4GHz; Chipset SiS 645DX; 5xPCI;
Gigabyte GA-M720-US3 rev 1.0 4.6 Works fine (downvolted to 1.1V)
Gigabyte GA-MA790GP-UD4H 3.30 Works fine
Gigabyte K8-NS-ULTRA 2.9.x-3.7 Excelent work, including both onboard ethernet (100 and 1000 lan)
Gigabyte GA-MA770-DS3 (rev. 2.0) 3.10 Works fine and extreme stable include onboard LAN, IDE DOM can load normally
Chipset P35 (Tested Using Gigabyte GA-P35-DS3L & Abit IP35) 3.7 Work fine but only with SATA, not IDE (Include DOM), bellow v3.7 problem with SATA too
Microsoft  Virtual PC 2007 3.7 Installs and and tries to boot.
VMware Workstation v6.0.3 3.7 Runs Wicked Fast! I have had up to 8 Ethernet interfaces running simultaneously.
VMware ESXi v4 3.30 Select IDE type for virtual disk - works perfectly!
Xen 3.2.1 on Intel C2Q 4.x Installs and runs fine on HVM bootloader using Intel VT technology. Even switches to RouterOS console from Dom0 shell. Ethernet interfaces work perfectly. Do not install xen/kvm RouterOS packages!
DFI AD73 Pro (Chipset VIA KT266A/VT8233ACD) 2.9.x-3.30 Works fine. All 5 PCI's ocupied with 1 x LAN and 6 x R52H's (3 in RouterBoard11 and 3 in RouterBoard14!)
DFI AK75-EC (Chipset VIA KT133A/686B) 3.14-3.30 Stable. All PCI's ocupied with LAN, miniPCI-PCI adapters fitted with R5H/R52H's and XR5's
Fujitsu Siemens Primergy RX100S5 3.1, 3.7, 3.22 Can Install from Netinstall with RAID (LSI) Controller enable. Can't install from CD and Netinstall with only SATA or PATA mode. But NOT RUN
MSI 785GM-E51 4.11 Works fine, booted from USB stick, integrated LAN working

Ethernet chipsets

Vendor Model ROS version Result
3Com 3c905B Cyclone 100BaseTX 2.9.51 Works! Extremely reliable, doesn't fully support tagged vlans
3Com  3cSOHO100-TX [Hurricane] (rev: 48) 3.14rc1 Works
3Com 3c905C-TX/TX-M [Tornado] (rev: 120) 2.9.51 Works! Extremely reliable, doesn't fully support tagged vlans
3Com  3c905C-TX/TX-M [Tornado] (rev: 116) 2.9.51 Works! Extremely reliable, doesn't fully support tagged vlans
3Com 3c905B-FX Fast Etherlink XL FX 100baseFx [Cyclone] (rev: 0) 2.9.43 Works but no link in Winbox and no Graph in Dude !!!!
Intel S82557 10/100MBit 2.9.43 works
Intel PWLA8391GT PRO1000/GT 3.7, 3.1, 2.9 Extremely Stable, used for years
Intel PWLA8391GTL PRO1000/GT 3.4 Extremely Stable, used for years
Intel 82575EB & 8257GB 3.15 Added support
Intel 82576 Gigabit ET Quad port 4.5 Not recognized
Intel 82572EI (EXPI9300PTBLK) 4.5, 4.6 Works
Intel 82572GI (EXPI9400PTBLK) 4.5 Works
Intel 82574L (EXPI9301CT) 5.0 beta 1 Supported in ROS 5 / Works
Intel 82571EB (EXPI9404PT) QUAD 4.6 Works
Intel S82557/S82555 10/100 Mbit TX 2.9.50 / 3.16 Works Stable! FCC ID:EJMNPDSPD035
Intel PRO 1000 MT 2.9.51 Works
Intel 82541GI/PI Gigabit Ethernet Controller (rev: 5) 2.9.49 Working
Intel 10Gbit Ethernet PCI Express 3.17 Works
Intel 82557/8/9 Ethernet Pro 100 (rev: 5)/Dual ports(Two ports/2-port)/RJ-45" 4.10 Works, fine!
D-Link DFE-528TX rev. E1 3.13 Works
D-Link DFE-580TX 4-port 3.0 beta 5 Bad card, not recommended. Hangs router
D-Link DFE-530/538TX 2.9.43 - 3.x Works well, no apparent problems.
D-Link DUB-E100 USB 3.18 added support, reported to be working
Marvell 88E8001 Gigabit Ethernet Controller (rev: 20) 3.13 Works
Marvell 88E8056 3.6 reported to be working with some BIOS setting enabled
DECchip 21143 (ZYNX ZX410 4-port cPCI) 2.9.51 Working
Realtek RTL-8169 Gigabit Ethernet x4 (rev: 16) 3.0-3.11 Working Extremely reliable, used 4 mounts
Realtek RTL8111 (10/100/1000Mbit) 3.10 Seems to be working only in older RouterOS v3 releases, v3.10 and before.
Realtek RTL8111C, RTL8111DL (10/100/1000Mbit) 4.6 - 4.11 Working
Realtek RTL8139C+ 3.14 Works
Realtek RTL8139D 3.x Some work, others don't. Check for yourself.
Realtek RTL-8139/8139C/8139C+ (rev: 16) 4.9 & 4.10 Works, fine!
Realtek RTL-8029(AS) (rev: 0)" 4.9 & 4.10 Works, fine!
ZNYX ZX346Q 3.27 Works
VIA VT6102 [Rhine-II] (rev: 67)" 4.9 & 4.10 Works, fine!

x86 Systems

Model ROS version Result
Dell Optiplex GX1 2.9.x-3.0 Intel onboard/cpu 450-600Mhz, eth:3com, best for wirless stations; uptime over 200d, no problems at all.
Compaq Presario 2282 2.9.43 With 3c905 [Boomerang], no apparent problems
Dell GX100 2.9.x - 3.7 Intel onboard, 2 free pci, Intel cpu
Dell GX240 2.9.x - 3.7 Intel onboard, 2 free pci, Intel cpu, IDE HDD.
Dell GX260 2.9.x - 3.7 Intel onboard, 2 free pci, Intel cpu, IDE HDD.
Dell GX270 2.9.x - 3.7 Intel onboard, 2 free pci, Intel cpu. IDE HDD.
Dell GX280 2.9.x - 3.7 Intel onboard, 2 free pci, Intel cpu, SATA HDD.
Dell Dimension XPS GEN 3 2.9.x Lan Onboard, 4 free pci, Intel cpu , SATA HDD ( Excellent Stability )
Dell Inspiron Desktop 518 2.9.x - 3.7 After netinsall stuck on "loading system"
Dell PowerEdge 860 3.x 1U Rackmount, 2x Broadcom Gigabit onboard, 1x Intel CPU (many options), 1 PCI/1 PCIe or 2 PCIe riser options, SATA HDD ONLY. (some issues with floppy netinstall)
Dell PowerEdge R200 >= 3.19 recommended Severe stability and clock issues with non-current ROS. Works like a top on 3.19 though. Also, if using an SATA-to-CF converter, the license key for the CF card in an R200 will only transfer to other R200's without Mikrotik reissuing it.
Dell PowerEdge R210 5.1 - 5.6 1U Rackmount. Half-depth (39cm) chassis. Dual port on-board Broadcom 5716 Gigabit Ethernet controllers. Single CPU on Intel 3420 Motherboard Chipset. Works OK and stable, once installed. Some issues with NetInstall - PXE boot works OK but install can't continue (says waiting for drivers...). Tested with Intel Gigabit ET Quad Port Server Adapter - works perfectly.
Dell PowerEdge R310 5.0rc7 1U Rackmount. 2 x on-board Broadcom 5716 Gigabit Ethernet controllers. Single CPU on Intel 3420 Motherboard Chipset. Works OK and stable, once installed. Some issues with NetInstall - PXE boot works OK but install can't continue (says waiting for drivers...). Tested with Intel Gigabit ET Quad Port Server Adapter - works perfectly.
Dell PowerEdge 2950 3.x 2U Rackmount, Optional Redundant Power Supplies, 2x Broadcom Gigabit onboard, 2x Intel CPU (many options), 2- 8xPCIe & 1- 4xPCIe Standard (other risers available), SATA HDD ONLY, 2x internal USB - MUST SPECIAL ORDER WITHOUT RAID CONTROLLER. (some issues with floppy netinstall)}
HP Proliant DL380 G5 3.17 Works, but only if installed from CDROM (Netinstall to Windows mounted HDD causes issues)
Asus EEE PC 701 3.x SFF Laptop, 1x10/100 ethernet (Not detected), Stock Wireless unsupported (AR5007E In Mini-PCIX slot), 630/900Mhz processor, 512MB RAM, 4GB SSD (Not detected), USB2.0 Bootable, SDHC Reader functions as a USB Stick
Dell PowerEdge SC1425 3.x Rackmount, Intel Xeon 2.8 1MB 800FSB, 1024MB DDR2 PC3200 ECC, 2x Intel 82541GI Gigabit Ethernet, HD150gb SATA, USB works, very stable
Fujitsu Siemens Primergy RX100S5 3.7, 3.22 Can Install from Netinstall with RAID (LSI) Controller enable. Can't install from CD and Netinstall with only SATA or PATA mode. But NOT RUN
Toshiba Magnia SG20 2.9.44 CPU Celeron, VIA chipsets, onboard LAN Realtek and Intel, IDE HDD, PCMCIA tested with Orinoco Silver, miniPCI LT WinModem not work
Advantech FWA-3800 4.11 CPU Intel Core2 Duo 2,93GHz, 2GB RAM DDR2, 6 x Intel 1Gbps PCIe NIC, 1U size, works good as BGP router

Embedded Controllers

Model ROS version Result
WRAP.1E-2 2.9.51, 3.7 3 Ethernet, 1 miniPCI, 128 MB - Working
WRAP.2E 2.9.51, 3.7, 3.9, 3.10 1 Ethernet, 2 MiniPCI, 128 MB - Work fine
ALIX 2-2 2.9.48 2 Ethernet, 2 miniPCI - Working
Adlink cPCI-6770 Low Power Pentium III 2.9 and 3.0 CompactPCI CPU Module - Working, excellent performance!
Advantech PCA-6751 2.9.49 Working
Soekris 4801-50 2.9.48 3 Ethernet, 128MB, CF 512MB - Working
Soekris 4826-48 3.10 233 Mhz CPU, 128 Mbyte SDRAM, 1 Ethernet, 1 Serial, 256 Mbyte CF Flash, 2 Mini-PCI sockets, PoE. Limited power available/runs only 1 high power card (@26dB) along with another lower power card (@17dB)
Soekris net4801-48/50 + lan1641 3.22 All 7 (3+4) ethernet works, USB works (tested with Huawei 3G modem), extra serial port works. And RouterOS installed on CF card.
ALIX 2C0 2.9,3.0 2 Ethernet, 2 miniPCI ,128Mb 433Mhz Amd Geode- Working Perfect
ALIX 2C1 2.9,3.0 2 Ethernet, 2 miniPCI ,128Mb 433Mhz Amd Geode- Working Perfect
ALIX 2C3 2.9,3.0 2 Ethernet, 2 miniPCI ,256Mb 500Mhz Amd Geode- Working Perfect
ALIX 3C1 2.9,3.0 2 Ethernet, 2 miniPCI ,128Mb 433Mhz Amd Geode- Working Perfect
ALIX 3C2 2.9,3.0 2 Ethernet, 2 miniPCI ,256Mb 500Mhz Amd Geode- Working Perfect
ALIX 2D13 5.2 3 Ethernet, 1 miniPCI ,256Mb 500Mhz Amd Geode- Working Perfect

3G cards

Huawei E169 USB modem (used by Tele2)
Model Tested RouterOS version Comments Format
AirPrime/Sierra PC 5220! v3
Alcatel One Touch X020X USB v5RC10 didn't work, probably need to do it like usb_modeswitch does it USB
AnyData ADU E100A

(aka "USB Wireless HSDPA/UMTS 2.1GHz GSM/GPRS/EGPRS 900/17000MHz/CDMA 1x EVDO Rev.A")

v3.14
AnyData ADU 500A USB

(aka "USB Wireless HSDPA/UMTS 2.1GHz GSM/GPRS/EGPRS 900/1800MHz/CDMA 1x EVDO Rev.A")

v3.14 USB
Audiovox PC5220 CDMA Dual Band 1XEV-DO PC Card v3
C-motech CNU-680 CDMA 1x EV-DO 450Mhz USB Modem (used by Triatel) v3.22
Dell 5520 v3
Ericsson_F3507g_Mobile_Broadband_Module V3.28 Set init string AT+CFUN=1, data channel and info channel to 3.
Huawei E226 USB modem, 3.25
Huawei E220 USB modem, E200BIS 3.0rc8
3.22
Huawei E180 USB modem 3.20
Huawei E1550 v3.26
Huawei E1553 (USB) v4.6
Siemens M20 v3.28
Huawei Mobile Connect Model E620 (3G); v3
Kyocera KPC650 v3
Nokia CS-17 (USB) v5.0 data channel=2, info channel=4
Novatel EU740 v3
Novatel EU870 v3
Novatel EV620 CDMA/EV-DO v3
Novatel Merlin ES620 / Merlin ES720 / Ovation U720 v3
Novatel Merlin ES620 SM Bus v3
Novatel Merlin S720 (HSDPA); v3
Novatel Merlin XU870 HSDPA/3G v3
Novatel U720 Wireless CDMA Modem v4.5
Novatel U730 (Wireless HSDPA Modem) v3
Novatel Wireless CDMA card v3
Option Fusion UMTS Quad-GPRS (Vodafone Globetrotter); v3.4
Option Globetrotter HSDPA USB (aka Teltonika ModemUSB/H7.2 U3G150) v3
Option Qualcomm 3G WCDMA Model M00201-10886 miniPCI-e v3.27 works also in RouterBOARD with miniPCI-e slot and SIM slot (SIM slot required)
Option Qualcomm 3G CDMA Model M00301 (GTM380) miniPCI-e v3.28 works in RouterBOARD 411U with miniPCI-e slot and SIM slot (SIM slot required). Set data channel and info channel to 3.
Option Qualcomm 3G CDMA Model M00401 (GTM382) miniPCI-e v3.28 & v4.6 works in RouterBOARD 411U with miniPCI-e slot and SIM slot. Set data channel and info channel to 3. Performance on CZ O2 in Prague HSDPA connection about 2.6Mbit download and 0.7Mbit upload. Latency between 100-300ms. Application based on this on http://carlive.cz [1]. UPDATE: connection freezes sometimes, reboot of routerboard doesn't help, it's needed to disconnect from power supply and reconnect again to get it working.
Ericsson 3G F3607gw miniPCI-e v3.28 works in RouterBOARD 411U with miniPCI-e slot and SIM slot (SIM slot required). Set data channel and info channel to 2. Set init string AT+CFUN=1
Sierra Aircard 595 v3
Sierra Aircard 595U USB Sprint Card v3
Sierra Wireless USB 308 or AT&T Shockwave v5.0rc11 AT Commands are sent through Data Channel 2 or 3. Change this under Interface -> PPP, General Tab using Advanced Mode, or command line /interface ppp-client set 0 data-channel=2
Sierra Wireless AirCard 312U v5.2 Use Info and Data Channel 2. Modem also known in Australia as the Telstra BigPond Ultimate and works fine.
Sierra Wireless AirCard 580 v3
Sierra Wireless AirCard 595 v3
Sierra Wireless AirCard 597E v3
Sierra Wireless AirCard 597E v3
Sierra Wireless AirCard 875 v3
Sierra Wireless AirCard 880 v3.8
Sierra Wireless AirCard 880 E v3.8
Sierra Wireless AirCard 881 v3.8
Sierra Wireless AirCard 881 E v3.8
Sierra Wireless EM5625 v3
Sierra Wireless MC5720 v3
Sierra Wireless MC5720 v3
Sierra Wireless MC5725 v3
Sierra Wireless MC8705 v5.1 Works fine on RB411UAHR. Data and Info channel are 3. Suitable for 850,900 and 2100Mhz 3G networks. GPS not yet tested. Sim card slot required. Capable of HSPA+ speeds of 21Mbps down and 5.76Mbps up.
Sierra Wireless MC8755 v3 Users have reported that the device doesn't show up after shutdown, reboot is required. Init-string: ATE0V1&D2&C1S0=0+IFC=2,2;AT+CGDCONT=1,"IP","apn-string"; - where the apn-string is your correct APN. A reboot can be required after settings are changed, to make it working. Data and Info channel are 0.
Sierra Wireless MC8755 for Europe v3
Sierra Wireless MC8765 v3
Sierra Wireless MC8775 v3
Sierra Wireless MC8780 v3.8
Sierra Wireless MC5725 v3.18
Sierra Wireless MC5727 v3.18
Sierra Wireless MC8785 v3.18
Sierra Wireless MC8790 v3.18 Few models do not send echo for input commands, modem does not work properly.
Sierra Wireless MC8792 v5.2 Info works only in channel 3. Channels 4 and 5 has limited AT set. datachannel=4, infochannel=3
Sierra Wireless MC8781 v3.8
Sierra Wireless Sierra 598 (Sprint) USB v3.x
Sierra Wireless MP3G - EVDO v3.8
Sierra Wireless MP3G - UMTS/HSPA v3.8
Sierra Wireless Compass 885 (USB) v3.28 AKA Telecom New Zealand's new XT network. Works a treat.
Silicon Labs MobiData GPRS USB Modem v3.22
Sprint U301/301U 4G wireless card [2] v4.6 C-MOTECH Co, FW301DOWMX, QUALCOMM Patch 33504--Tested with v4.11 on RB433UAH, Data CH=1 Info CH=3 Phone #777 for Sprint in US USB
Sprint U300/300U 4G wireless card [3] v4.6 C-MOTECH Co, FW301DOWMX, QUALCOMM Patch 33504 USB
Verizon Express Network PC5220 (AirPrime 5220) v3
ZTE AC8700 v3.6
ZTE MF620 / MF622 v3
ZTE MF620 / MF622 (3G) v3.6
ZTE MF680 v5.4 Used by 3 in Sweden. Set data chanel to 1
ZTE MF668 v4.5 for Rogers Wireless (Canada) Set APN: isp.apn and Info & Data Channel to 1
T-Mobile (Germany) Web´n´Walk Box Micro (Huawei E220) v3.x
Vodafone (Germany) Easybox 2 (Huawei E220) v3.x
O2 (Germany) Surfbox Mini (Huawei E220) v3.x
E-Plus & Base (Germany) USB Minimodem (Huawei E220) v3.x
Huawei E600 v3.15
Novatel Merlin V640/XV620 v3.15
Novatel Merlin V620/S620 v3.15
Novatel Merlin EX720/V740/X720 v3.15
Novatel Merlin V720/S720/PC720 v3.15
Novatel Merlin XU870 HSDPA/3G v3.15
Novatel X950D v3.15
Novatel ES620/ES720/U720/USB720 v3.15
Novatel E725/E726 v3.15
Vodafone EU740/Novatel non-Vodafone EU740 v3.15
Vodafone K3565/Huawei E160 v3.23
Novatel EU850D/EU860D/EU870D v3.15
Novatel MC930D/MC950D v3.15
Novatel MC727/U727 v3.15
Novatel Expedite EV620 CDMA/EV-DO v3.15
Novatel Expedite EU740 HSDPA/3G, Dell Wireless 5500 Mobile/Dell Wireless 5505 Mobile v3.15
Novatel Expedite E720 CDMA/EV-DO v3.15
Novatel Expedite ET620 CDMA/EV-DO v3.15
Onda H600/ZTE MF330 v3.15
BP3-USB & BP3-EXT HSDPA v3.15
ZTE MY 39 (MSM 6500 based) v3.20
Cricket A600 v3.26
Globetrotter HSDPA Modem Option N.V. v3.26
Sony Ericsson MD300 v3.26
ZTE MF 626 v3.26
ZTE MF 627 v3.26
Pantech / UTStarcom UM175 v3.27 On Alltel's CDMA EVDO RevA network average 700-800kbps up and 2.4-2.8Mbps down
Novatel U760 v3.30
ZTE K3565-Z v4.4 Revision: BD_P673A2V1.0.0B09
Novatel Expedite EV620 v4.5
Novatel MC760 VMU v4.5
Franklin Wireless FW300DOWMX v4.5
Huawei EC1260 v4.5
Vodafone K3520-Z v4.6
Vodafone K3765 v4.6
Telstra 3G Elite v5.x
Vodafone Huawei K4505 v5.x Unlocked work fine on Thinkpad
Vertex VW 110 v5.x works perfect, tested on RB433UAH, v5.2
ZTE MF112 v5.x Power issues on mipsbe boards
Huawei ET127 v5.x
Huawei EC1261 v5.x
Huawei E173 v5.x
ZTE MF190 v5.x
ZTE MF102 v5.x Works! Possible that need to change data channel=2 and info channel=2
China TeleCom or ZTE AC682 support v5.x

Memory cards

NB! New flash cards need always formatting!

Legend:

  • V - works
  • X - doesn't work
  • ? - not tested
  • NA - not available for this RB
Model Type RB600 RB1000 RB433AH RB450G R493G
PQI 4GB 120x HiSpeed CF X  ? NA  ?  ?
2GB Transcend 133x CF X  ? NA  ?  ?
2GB Kingston 133x (Elite Pro, code CF/2GB-S2) CF V  ? NA  ?  ?
4GB Kingston 133x (Elite Pro) CF  ? V NA  ?  ?
4GB Kingston CF/4GBIN CF X  ? NA  ?  ?
8GB A-Data Speedy G08GNMC7B0095 CF V V NA  ?  ?
16GB A-Data Speedy CF V V NA  ?  ?
4GB Apacer Photo Steno IV 300X CF X X NA  ?  ?
1GB Sandisk Ultra II BB05024GA CF V V NA  ?  ?
2GB Sandisk Ultra II CF  ? V NA  ?  ?
8GB Sandisk Ultra II CF  ? V NA  ?  ?
8GB SanDisk Extreme III (200X,30MB/s) CF  ? V NA  ?  ?
2.5GB Seagate ST1 (ST625211CF) CF microdrive V V NA  ?  ?
8GB Seagate ST1 CF microdrive V V NA  ?  ?
64MB Nokia microSD NA NA ? V  ?
512MB Kingston microSD NA NA V  ?  ?
1GB Apacer microSD NA NA V  ?  ?
1GB Kingston (SDC/1GB) microSD NA NA  ? X  ?
2GB Kingston microSD NA NA X X  ?
2GB Traxdata microSD NA NA ? V  ?
4GB Apacer SDHC (class 6) microSD NA NA V X  ?
4GB Axiz microSD NA NA V  ?  ?
4GB Kingston microSD NA NA V  ?  ?
4GB Kingston SDHC (C04G JAPAN class 4) microSD NA NA V  ?  ?
4GB Maxell SDHC (class 2) P-series microSD NA NA  ?  ? V
4GB Transcend SDHC microSD NA NA V  ?  ?
4GB Sandisk Mobile Ultra Micro SDHC (with card reader) microSD NA NA  ? V  ?
8GB Sandisk SDHC (0733702482DLE) microSD NA NA V V  ?
8GB Sandisk Mobile microSDHC (SDSDQ-8192-A11M) microSD NA NA  ? V  ?
8GB Sandisk Mobile Ultra SDHC (Class 6) microSD NA NA  ? V  ?
8GB Kingston SDHC (Class 4) microSD NA NA V X  ?
8GB ADATA micro SDHC (AUSDH8GCL6) (Class 6) microSD NA NA  ? V  ?
16GB Sandisk micro SDHC (SDSDQ-16384-P36M) class 2 microSD NA NA NA X  ?
16GB Sandisk micro SDHC (0835B03279DQ) class 2 microSD NA NA V V  ?
2GB Sandisk micro SDHC class 2 microSD NA NA NA X V

Note: Pushing the "Kingston SDHC 8GB card" all the way into the socket caused the card not to work properly! It had to be pulled out ~1mm for it to work!

802.11a/b/g wireless cards

Model Form factor Platform ROS Result
TechnicLan TMP-5414A miniPCI All RouterBOARDs 2.9 / 3.x / 4.x Perfect, Stable
Compex WLM54AG-20 miniPCI RB1xx / RB3xx / RB4xx / RB5xx / RB6xx / x86 2.9 / 3.x / 4.x Perfect, Stable
Compex WLM54A-26 miniPCI RB1xx / RB3xx / RB4xx / RB5xx / RB6xx / x86 2.9 / 3.x / 4.x Perfect, Stable
SparkLAN WMIA-165G miniPCI RB1xx / RB3xx / RB4xx / RB5xx / RB6xx / x86 2.9 / 3.x / 4.x Perfect, Stable
SparkLAN WMIA-166AG miniPCI RB1xx / RB3xx / RB4xx / RB5xx / RB6xx / x86 2.9 / 3.x / 4.x Perfect, Stable
SparkLAN WMIA-166AGH miniPCI RB1xx / RB3xx / RB4xx / RB5xx / RB6xx / x86 2.9 / 3.x / 4.x Perfect, Stable
Alfa AWPCI 085 H miniPCI RB1xx/RB333/RB4xx/x86 2.9&3.x All just perfect
TP-Link TL-WN550/551 PCI x86 2.9&3.x Perfect 19dB rated, stable at 21
TP-Link TL-WN650/651 PCI x86 2.9&3.x Perfect 19dB rated, stable at 21. Unstable with compression activated
D-Link AG530 a/b/g (both rev.A1 and A2) PCI x86 2.9&3.x Perfect. Works perfect, in both 2.4 and 5.x GHz
D-Link DWL-G510 PCI x86 only 2.9.x tested Perfect. Tested Rev A1
D-Link DWL-G520 PCI x86 2.9.x & 3.x Works well.
D-Link DWL-G520+A/RaLink 2591 Chipset PCI x86 4.9 NOT Work!
Gigabyte b/g GN-WI01GT miniPCI-e x86 3.x Works also in RouterBOARDs with miniPCI-e slot
Senao NL-2511CD EXT2 PCMCIA x86&rb230 only 2.9x tested Perfect. Just about the most sensitive card i used, in the good sense. Only 11b.
Planet WL-8310 PCI x86 only 2.9.x tested Perfect. Stability.
Netgear WG311T 108 PCI x86 only 2.9x tested Perfect. stability
SMC SMCWPCIT-G PCI x86 3.x tested Perfect on A/B/G.
Wistron DCMA-81 miniPCI x86,rb 2.9.xx, 3.xx Perfect on A/B/G with or without compression.
Wistron DCMA-82 miniPCI rb 3.xx Works on some RB, but on 2/3 of my RB433 it causes the board to reboot when enabled. Many other people have had similar experiences. Not recommended. Maybe OK on 133
Senao NMP-8602 miniPCI x86&rb411 2.9x,3.x tested Perfect on a/b/g
Dbii F20 miniPCI RB411 & RB433 3.x tested Perfect on B/G, too thick for 3 in rb433
Dbii F50 miniPCI RB411 & RB433 3.x tested Perfect on A, too thick for 3 in rb433
Dbii F20-PRO miniPCI RB411 & RB433 3.x tested Perfect on B/G, too thick for 3 in rb433
Dbii F50-PRO miniPCI RB411 & RB433 3.x tested Perfect on A, too thick for 3 in rb433
Ubiquiti XR2 miniPCI RB433 3.x works as advertised, too thick for 3 in rb433
Ubiquiti XR5 miniPCI RB433, x86 3.x works as advertised, too thick for 3 in rb433
Ubiquiti SR9 miniPCI RB433 3.x works as advertised, thin enough to load 3 in RB433
Ubiquiti XR9 miniPCI RB411 & RB433 3.x works as advertised, thin enough to place cards above, but antenna port may contact cards below
Valemount KXS30SG miniPCI RB433 3.2 & 4.2 tested B/G only, no A. Big heat sink means card should be installed on highest mount when other cards being used. High power consumption can cause power problems, otherwise works perfectly.
Zcomax XG-650 miniPCI RB112 & RB433 4.2 & 4.6 Not working (driver doesnt work / exist). It has a TI TNETW1130GVF chipset.
AR5BMB5 miniPCI RB411,x86 3.xx, 4.3 Not working. Atheros chipset.

802.11n wireless cards

Model Form factor ROS Result
SparkLAN WMIA-198N miniPCI 4x, 5x Perfect, Stable
Compex WLM200N5-23 miniPCI 4.0b3 Perfect, Stable
Compex WLM200NX miniPCI 4.0b3 Perfect, Stable
Dbii F52N-PRO miniPCI 5.1 Stable
RouterBOARD R2N miniPCI 4.0b3 works
RouterBOARD R52N miniPCI 4.0b3 works
TP-Link Wireless N (2T2R) miniPCI 4.0b3 works
Ubiquiti SR71-A miniPCI 4.0b3 works
Ubiquiti SR71-A miniPCI 4.0b3 works

USB wireless cards

Model Form factor ROS Result
802 b/g/n AR9271 USB 5.0rc4 works

T1/E1

Model Form factor Platform ROS Result
Farsite FarSync TE1 PCI x86 3.15 supported

Note: Since v3.15 RouterOS doesn't support any Sync/T1/E1 cards except select Farsite models

GPS

Model Connection Platform ROS Result
EXAMPLE USB x86 3.30 supported

Storage controllers (SAS/SCSI/RAID)

Post only tests since RouterOS v5beta5

Brand Model Motherboard RouterOS Works
HP Smart Array E200i x86 v5rc1 No
3ware 3w-9xxx x86 v5rc8 Yes
Areca arcmsr x86 v5rc8 Yes
Megaraid Megaraid (some Dell servers) x86 v5rc8 Yes

LCD panels

Brand Model Motherboard RouterOS Works / Doesn't
Crystalfontz CFA-633v1.5 x86 v5RC10 Works
Crystalfontz CFA-633v1.3 x86 v5RC7-RC10 Didn't work