Force users to use specified DNS server

From MikroTik Wiki
Jump to: navigation, search

This is just simple firewall rule which will force all Your users behind RB to use DNS server which You will define.


In /ip firewall nat

add chain=dstnat action=dst-nat to-addresses=192.168.88.1 to-ports=53 protocol=tcp dst-port=53 
add chain=dstnat action=dst-nat to-addresses=192.168.88.1 to-ports=53 protocol=udp dst-port=53 

This rule will force all users with custom defined DNS server to use 192.168.88.1 as their DNS server, this rule will simply redirect all request sent to ANY-IP:53 to 192.168.88.1:53


--Marko 12:29, 6 July 2010 (UTC)