Manual:IP/Packing

From MikroTik Wiki
Jump to navigation Jump to search

Overview

IP Packing provides packet packaging service on network links. It allows simple packet aggregation into larger packets and compression of contents of packets.

Requirements

Packet packing is part of system package and has to have discovery protocol enabled on interface.

Configuration

Menu: /ip packing

It required to have configuration in two places, both routers should be set up symmetrically:

  • ip packing - to enable packet aggregation and/or compression on interface
  • /ip neighbor discovery- to enable discovery protocol on the interface

Packing configuration

Property Description
aggregated-size (20 .. 16384 default:1500) size of aggregated packet that packing will try to achieve before sending packet over network
disabled (yes|no) state of packing rule, if value is yes it will be ignored and will not be part of active configuration
interface (interface name) packing will try to aggregate and/or compress packets from this interface
packing (simple|compress-all|compress-headers|none) action it should perform when packet is leaving interface packing rule is configured on.
  • simple - do just aggregation of packets
  • compress-all - do aggregation and attempt to compress headers and payload of packet
  • compress-headers - do aggregation and attempt to compress headers and leaving payload of packet as is
  • none - send packets as is
unpacking (simple|compress-all|compress-headers|none) action it should perform when packet is received on interface packing rule is configured on.
  • simple - unpack received packets from aggregated packet received from interface
  • compress-all - unpack aggregated packet and uncompress headers and payload of packet
  • compress-headers - unpack aggregated packet and decompress headers of packet
  • none - do nothing with received packet
Icon-warn.png

Warning: Router should be seen as neighbour of router over interface you want to enable packing on. If in neighbour list there are no entry indicating packing, packing is not working!


Icon-note.png

Note: Packing may increase latency on the link it is configured on!


Example

Router-A and Router-B are connected with cable with interface ether1 on Router-A and ether3 on Router-B. This example will aggregate packets coming from Router-A, but will leave packets from Router-B intact On Router-A:

  • make sure discovery is enabled
 /ip neighbor discovery set ether1 discover=yes
  • add packing rule for the interface
 /ip packing add interface=ether1 aggregated-size=1500 packing=simple unpacking=none

On Router-B:

  • make sure discovery is enabled
 /ip neighbor discovery set ether3 discover=yes
  • add packing rule for the interface
 /ip packing add interface=ether3 aggregated-size=1500 packing=none unpacking=simple