Manual:Interface/Gre6

From MikroTik Wiki
Jump to navigation Jump to search
Version.png

Applies to RouterOS: v5.11+

Summary

Sub-menu: /interface gre6


Interface gre6 is a Generic Routing Encapsulation (GRE) tunnel over IPv6 network. It can encapsulate IPv4 or IPv6 network packets and transfer them over the tunnel.


Properties

Property Description
clamp-tcp-mss (yes | no; Default: yes)
comment (string; Default: ) Short description of the tunnel.
disabled (yes | no; Default: no) Enables/disables tunnel.
dscp (inherit | integer [0-63]; Default: ) Set dscp value in Gre header to a fixed value or inherit from dscp value taken from tunnelled traffic
ipsec-secret (string; Default: ) When secret is specified, router adds dynamic ipsec peer to remote-address with pre-shared key and policy with default values (by default phase2 uses sha1/aes128cbc). Both local-address and remote-address of the tunnel must be specified for router to create valid ipsec policy.
keepalive (integer [1..4294967295]; Default: ) Tunnel keepalive timeout in seconds. By default keepalive is disabled.
l2mtu (integer [0..65536]; Default: 65535) Layer2 Maximum transmission unit.
local-address (IP; Default: ) IPv6 address that will be used as local tunnel end.
mtu (integer [0..65536]; Default: 1476) Layer3 Maximum transmission unit.
name (string; Default: ) Name of the tunnel.
remote-address (IP; Default: ) IP address of remote tunnel end.

Example

on router 1:

/interface gre6 add local-address=2001:db8:bad:ee1::a remote-address=2001:db8:f00:baa::b keepalive=5

on router 2:

/interface gre6 add local-address=2001:db8:f00:baa::b remote-address=2001:db8:bad:ee1::a keepalive=5