Manual:System/Store

From MikroTik Wiki
Jump to navigation Jump to search
Version.png

Applies to RouterOS: v3, v4+, v5, <v6.19

Store manages storage devices used by RouterOS various facilities.

float
Icon-warn.png

Warning: Since v6.20 release the way how Disks and Stores as managed are changed. If your RouterOS device is running mentioned release or anything newer please refer to this [1] article.


Currently Store can be used for:

  • Webproxy
  • User Manager
  • the Dude

This is especially useful for RouterBOARD devices with SD/CF slots - as the built-in storage is quite small, an external drive comes in very handy when you want a big User Manager database.


You can add as many external or secondary drives as you want, and select any number of them for each of the mentioned feature use. For example User Manager could be used on 3 disks, one of them would be the active database, and the rest would be backups. You can then add a fourth disk, copy the active data to it - unplug it - and move to another server, to keep using the actual database.

This means migration and backup made easy!

Icon-note.png

Note: For proper operation router needs to be rebooted after adding or removing external storage.


Creating a Store instance

[normis@demo.mt.lv] /store> print
Flags: X - disabled, A - active 
 #   NAME                      TYPE                    DISK                    STATUS    
 0 A web-proxy1                web-proxy               system                  active    
[normis@demo.mt.lv] /store> add 
 activate  comment  copy-from  disabled  name  disk  type  

[normis@demo.mt.lv] /store> add name=webproxy_backup disk=disk1 type=web-proxy activate=no

This will add a new storage place for Webproxy on disk1, and will set it as inactive.

Activate new store instance to save proxy cache on secondary disk (other proxy settings configured separately from /ip proxy menu),

[normis@demo.mt.lv] > store activate webproxy-backup

E.g. RB1000 with populated CF Card slot and User Manager, one can add the CF card for use by User manager to store all it's data as follows

/store add disk=CF1 type=user-manager activate=yes

Store management

Sub-menu: /store

Properties

Property Description
activate (yes | no; Default: no) Whether to activate this store as primary.
comment (string; Default: ) Short description of an item.
disabled (yes | no; Default: no) Whether to disable store.
disk (string; Default: ) Name of the disk (from /store disk menu) used by this store.
name (string; Default: ) Descriptive name of the store
type (user-manager | web-proxy; Default: ) Configured type of the store. Two options are available, either store is used by web-proxy or by user-manager.

Read-only Properties

Property Description
status (backup | active | invalid) Current status of the store. Shows whether store is used as backup,active or some of the config is invalid.

Menu specific commands

Property Description
activate (<store_name>) Makes specified store as active if previously was in backup state.

Disk management

Sub-menu: /store disk

Read-only Properties

Property Description
free-space (integer [KiB]) Shows the free space left on the disk.
name (string) Name of the disk
status (strung) Shows the current status of the disk, can be ready, formating etc.
system (yes | no) Shows whether disk is used as system drive
total-space (integer [KiB]) Shows total available disk space

Menu specific commands

Property Description
check-drive (<drive_name>) Check the drive for errors.
clean-drive (<drive_name>) Clean the drive
format-drive (<drive_name>) Format the file system in usable by RouterOS file system.
Icon-note.png

Note: Before using drive as a storage device it must be formatted. Before doing so, make sure that all sensitive data is backed up.