Manual:The Dude v6/Logs

From MikroTik Wiki
Jump to: navigation, search
Version.png

Applies to RouterOS: v6.34+

After v6.36rc13

Starting with above mentioned release candidate build version. The Dude now uses RouterOS log system for storing it's logging data.

Icon-note.png

Note: Old logs will not be moved to new log.


To enable dude logs in ROS new logging rule with dude topic must be added

/system logging add topics=dude

To view dude logs you now need to connect to the Dude server host via winbox/webfig/cli and check the Log section.

By default dude logs will mix with system logs.

11:31:06 dude,event 10.5.104.241: system,info device changed by admin 
11:32:50 dude,event 10.5.104.241: system,info changed email settings by admin 
11:33:21 dude,event Service disk on Termo_PowerCycle is now up (ok) 
11:34:40 system,info changed email settings by admin 
11:35:24 dude,event Service VNC-server-check on 10.5.8.160 is now up (ok) 
11:36:28 system,info,account user admin logged in from 10.5.104.252 via telnet 
11:37:13 system,info,account user admin logged in from 10.5.104.252 via telnet 


For easier sorting new view for these logs can be created

  • Add new loging action specifically for The Dude
/system logging action add disk-file-name=dude-logs-main name=dudeLogsMain target=disk
  • Add logging rule for dude topic with action that was just created.
/system logging add action=dudeLogsMain topics=dude

RouterOS log configuration

For more info on logging configuration refer to wiki article: Logs in RouterOS

To view The Dude log \ syslog entries

The Dude client:
Dude-syslog-view.JPG

Icon-note.png

Note: Use "Ctrl + F" key combination to initiate search.


Webfig view:
Log-view-0.JPG

Winbox view:
Log-view-1.JPG

CLI:

To search just dude view entries:

/log print where buffer~"dude"
[admin@test-dude] > /log print where buffer~"dude" 
12:02:50 dude,event 10.5.104.241: system,info changed email settings by admin 
12:03:36 dude,event Service disk on Termo_PowerCycle is now down (timeout) 
12:05:21 dude,event Service disk on plus.lan is now up (ok) 
12:05:21 dude,event Service rnd 50:50 on gateway.lan is now down (failed 98 >= 50) 
12:05:23 dude,event Service ping on 10.5.8.160 is now up (ok) 
12:06:24 dude,event Service VNC-server-check on 10.5.8.160 is now up (ok) 

To look for something specific in log message.

/log print where message~"10.5.104.241" 
[admin@test-dude] > /log print where message~"10.5.104.241" 
10:43:21 dude,event -- 2k.lan --: 10.5.104.241: system,info,account user admin logged in ...
10:43:24 dude,event -- 2k.lan --: 10.5.104.241: system,info,account user admin logged out  ...
10:47:42 dude,event -- 2k.lan --: 10.5.104.241: system,info changed email settings by admin 
10:52:42 dude,event -- 2k.lan --: 10.5.104.241: interface,info ether1 link up (speed 1G, full duplex) 
10:52:42 dude,event -- 2k.lan --: 10.5.104.241: interface,info ether2 link up (speed 1G, full duplex)

Before v6.36rc13

The Logs Pane shows lists of events in the Dude software. There are built in log files:

  • Action - Shows when devices or settings are added or changed
  • Debug - Shows critical information
  • Event - Shows when somebody logs in, when Dude server starts and stops or changes something in server.
  • Syslog - Saves logs from remote devices, like RouterOS systems which support remote logging to Syslog

The built in Logs cannot be changed or cleared.

This pane also allows you to set up new log, that can be used for local action logging, and for the built-in Syslog.

Dude-logs.JPG

When adding a new log file, you can set the following settings:

  • Name - The name of your new log
  • Start new file - How often to start a new file, helps reduce the number of log entries in one file, and organizes logs for quicker navigation
  • Logs to keep - how many log files shoud the Dude keep before removing old ones
  • Buffered entries - how many entries to buffer in memory before writing to file

Dude-logs-new.JPG

When double-clicking an existing log, you will be able to see the same settings, and in addition - the existing log files:

Dude-logs-settings.JPG


It is also possible to import a log file in case you want to combine logs from some previous location with the current Dude logs.

Old log files can be deleted, but current log, and buffered log (which is shown in the Logs pane) can't be cleared.