Manual:Trial user limits

From MikroTik Wiki
Jump to: navigation, search
Version.png

Applies to RouterOS: v6.34+

Trial user bandwidth limitations

Starting with RouterOS v6.34rc12 additional options for hotspot trial user bandwidth limitation are now added. The trial user now have it's own entry in user table: "default-trial". Same as for standard user entry you can apply bandwidth limitations for it:

  • Limit uptime ( Used if trial-uptime-limit in server profile is set to "0" )
  • Limit Bytes in
  • Limit Bytes out
  • Limit Bytes total

If only this one default-trial user entry is there. Then limits applied in it will be used for all of hotspot servers on this device. However if you have multiple hotspot servers running on the device and you want different trial user limits for each of them. Then what you need to do is to create individual user named "default-trial" each assigned to required server.

One additional field that is allowed for modification on this user is:

  • Routes
Icon-note.png

Note: Rest of the fields default-trial user entry are read only and are not modifiable.


Configuration examples

Two "default-trial" users added in addition with one that is already added by system, which stays unmodified and dormant.

Static entries which you added will contain combined stats from all dynamically created trial users under them. And each dynamic user entry will only contain it own stats by mac-address to which it is assigned.

Trial-working.jpeg

Icon-note.png

Note: You can also type in limit values as "10M", "100M", etc.


Trial-working2.jpeg

Example in cli

Icon-note.png

Note: You can also type in limit values as "10M", "100M", etc.


/ip hotspot user
add comment="counters and limits for trial users" limit-bytes-total=100000000 name=default-trial server=hotspot2.lan
add comment="counters and limits for trial users" limit-bytes-total=300000000 name=default-trial server=hotspot1.lan
[admin@LOW-hotspot] > /ip hotspot user print detail
Flags: * - default, X - disabled, D - dynamic 
 0 * ;;; counters and limits for trial users
     name="default-trial" limit-bytes-total=500000 uptime=0s bytes-in=0 bytes-out=0 packets-in=0 packets-out=0 

 1   name="test" password="test" profile=default uptime=0s bytes-in=0 bytes-out=0 packets-in=0 packets-out=0 

 2   ;;; counters and limits for trial users
     server=hotspot2.lan name="default-trial" password="" profile=default limit-bytes-total=100000000 uptime=36s 
     bytes-in=48198739 bytes-out=51814030 packets-in=49958 packets-out=48374 

 3   ;;; counters and limits for trial users
     server=hotspot1.lan name="default-trial" password="" profile=default limit-bytes-total=300000000 uptime=2m59s 
     bytes-in=145477719 bytes-out=204557092 packets-in=168686 packets-out=187216 

 4 D server=hotspot2.lan name="T-E8:50:8B:1C:95:7D" password="" mac-address=E8:50:8B:1C:95:7D profile=default limit-uptime=30m 
     limit-bytes-total=100000000 uptime=36s bytes-in=48198739 bytes-out=51814030 packets-in=49958 packets-out=48374 

 5 D server=hotspot1.lan name="T-E8:50:8B:1C:95:7D" password="" mac-address=E8:50:8B:1C:95:7D profile=default limit-uptime=30m 
     limit-bytes-total=300000000 uptime=2m30s bytes-in=144501472 bytes-out=155509849 packets-in=150786 packets-out=154342 

Side notes

such settings for trial user as:

  • Trial uptime limit
  • Trial uptime reset
  • Trial user profile

You still configure in each of specific hotspot server profile entries under which you will be using this trial profile.

Trial-working1.jpeg

Example in cli

/ip hotspot profile set (number or profile-name) trial-uptime-limit=00:30:00 trial-uptime-reset=1d trial-user-profile=default

[ Top | Back to Content ]