Talk:Routing local + international + unshaped traffic through 3 separate adsl accounts

From MikroTik Wiki
Jump to: navigation, search
Hey there,

thank you, thank you, thank you!!! I've been looking for this for about a year and a half now and at last some one's ingenuity is paying off :)

The only question now is the changing gateway IP... I've noticed that you get a different gateway when you get supplied with a new IP from a different IP range. Do you know if this is localised (as in Johburg / CPT / DBN for instance)? Or do you just get random ranges no matter where you are lacated...and if so, how do you handle the gateway IP change?

Could you just add all the gateways as routes and then when ever the gateway you are supplied with will be used? I.E. something like this:

/ip route add dst-address=17.255.248.0/23 gateway=41.144.2.1 distance=2

/ip route add dst-address=17.255.248.0/23 gateway=165.146.180.1 distance=2

/ip route add dst-address=17.255.248.0/23 gateway=xxx.xxx.xxx.xxx distance=2

Or would this interfere with each other?

I really hope there is a simple solution for this :)

Regards.

Not working

Hey there.

I might be doing something wrong, but I followed the suggestions bit by bit and I can't get it to work. As soon as I add the local route and try to connect to a server on that range, it doesn't go trough. I tried using the local interface, the local account gateway IP and even had the local and international internet on separate ports...

I'm running the hotspot system b.t.w., but I'm sure this shouldn't interfere...or will it?

Please can I contact you for some assistance??

Nope, it's working

Appologies - for some strange reason it started working after my 4th reconfiguration. Don't ask me why though... One thing for new users, remote connection will how ever need to be to the "Local" IP and not the "International" IP (due to new routes). In my eyes you are legend - to the auther of this topic. Thank you.