Manual:PoE-Out

From MikroTik Wiki
Jump to: navigation, search
Version.png

Applies to RouterOS: v6.0 +

Summary

Sub-menu: /interface ethernet poe


This page describes how PoE-Out (Power over Ethernet) feature can be used on MikroTik devices with at least one PoE-Out interface. MikroTik uses RJ45 mode B pinout for power distribution over spare pairs, where the PoE is passed trough pins 4,5 (+) and 7,8 (-).


MikroTik supported PoE-Out standards

MikroTik devices can support some or all of the following PoE standards:

  • Passive PoE-Out up to 30 V - PoE standard, which does not require negotiation between PSE (Power Sourcing Equipment) and PD (Powered Device). For PoE-out uses the same voltage as supplied to the PSE (Power Sourcing Equipment). PoE-Out Standard for devices which supports input voltage up to 30 V. PD resistance on spare pairs should have range from 3kΩ to 26.5kΩ. (e.g. hEX PoE lite, RB3011UiAS-RM, RB2011iL-IN.)
  • Passive PoE-Out up to 57 V - Works same as low voltage (up to 30 V) PoE-Out, but is also capable to deliver high voltage over PoE ports. The output voltage depends from the power source connected to PSE. Can power up af/at compatible devices, which accepts power over 4,5 (+) and 7,8 (-), and does not require PoE negotiation. PD resistance on spare pairs should have range from 3kΩ to 26.5kΩ. (e.g. cAP ac, hAP ac, wsAP ac lite.)
  • IEEE Standards 802.3af/at - Also called PoE Type 1/PoE+ Type 2, are PoE standards Defined by the IEEE. The aim of these standards is to reduce incompatibility between vendors. MikroTik PSE with af/at support is capable of powering both a Type 1 and a Type 2 PD. Valid PD should have PoE-In resistance from 23.75kΩ to 26.25kΩ. MikroTik devices which support af/at standard can also switch to Passive PoE-Out mode. (e.g. hEX PoE, CRS112-8P-4S-IN, CRS328-24P-4S+RM.)

Each PoE-Out implementation supports overload and short-circuit is detection.

Icon-note.png

Note: Some MikroTik devices support all of the described standards (e.g. hEX PoE, PowerBOX Pro, CRS112-8P-4S-IN etc...)


PoE-Out Configuration

PoE Configuration is supported on all MikroTik devices with PoE-Out interfaces, the configurations can be edited from the RouterOS and SwOS interfaces.

RouterOS

Usage

RouterOS provides an option to configure PoE-Out over Winbox, Webfig and CLI, basic commands using the CLI are

Property Description
print () Prints PoE-Out related settings.
export () export is displayed under /interface ethernet menu.
monitor (string| interface) Shows poe-out-status of a specified port, or all ports with /interface ethernet poe monitor [find] command.
power-cycle (time:0..1m |; Default: 5s) Disables PoE-Out power for a specified period of time.

Global Settings

Some MikroTik PoE-Out devices support global PoE setting which can be configured under /interface ethernet poe settings menu. Global setting ether1-poe-in-long-cable feature disables strict input/output current monitoring (short detection) to allow the use of PoE-Out with long ethernet cables.

Property Description
ether1-poe-in-long-cable (yes | no) Setting to yes will disable short detection on all poe-out ports to enable the use of longer ethernet cables. This is potentially dangerous settings and should be used with caution
Icon-note.png

Note: Global setting of ether1-poe-in-long-cable can also affect PoE-Out behaviour on PSE which is powered using a DC connector


Port Settings

PoE-Out can be configured under /interface ethernet poe menu. Each port can be controlled independently.


Property Description
name () Name of an interface
poe-out (auto-on | forced-on | off; Default: auto-on) Specifies PoE-Out state
  • auto-on - the board will attempt to detect if power can be applied on the port. For power-on to happen there should be resistance on spare pairs in the range from 3kΩ to 26.5kΩ
  • forced-on - detection range is removed. As a result power over Ethernet will be always on
  • off - all detection and power is turned off for this port
poe-priority (integer:0..99 | any; Default: 10) poe-priority specifies the importance of PoE-Out ports, in cases when a total PoE-Out limit is reached, interface with the lowest port priority will be powered off first.

Highest priority is 0, lowest priority is 99. If there are 2 or more ports with the same priority then port with the smallest port number will have a higher priority. For example, if ether2 and ether3 have the same priority and over-current is detected then PoE-Out on ether3 will be turned off.

Every 6 seconds ports will be checked for a possibility to provide PoE-Out if it was turned off due to port priority.
poe-voltage (auto | low | high; Default: auto) Feature which allows to manually switch between two voltage outputs on PoE-Out ports. Will take effect only on PSE with switchable voltage modes (CRS112-8P-4S-IN, CRS328-24P-4S+RM).

Power-cycle settings

RouterOS provides a possibility to monitor PD using a ping, and power-cycle a PoE-Out port when the host does not respond. power-cycle-ping feature can be enabled under /interface ethernet poe menu.

Property Description
power-cycle-ping-enabled (yes | no; Default: no) Enables ping watchdog, power-cycles port if a host does not respond to layer3 (ICMP) or layer2 (ARP-Ping) packets.
power-cycle-ping-address (IPv4 | IPv6 | MAC; Default: ) An address which will be monitored
power-cycle-ping-timeout (time:0..1h |; Default: 5s) If the host does not respond for more than <timeout> period of time, then PoE-Out port is switched off for 5s.
power-cycle-interval (time| any; Default: ) Disables PoE-Out power for 5s between specified interval. Not related with power-cycle-ping feature.


If power-cycle is enabled, /interface ethernet poe monitor will show actual status of the host and time when power cycle will be performed [1]

SwOS

SwOS interface provides basic PoE-Out configuration options:

  • PoE Out - Change between modes (auto/on/off)
  • PoE Priority - Change the Priority of port (0...99)

PoE-Out Monitoring

RouterOS

MikroTik devices with PoE-Out controller (not injector) provides port monitoring option. /interface ethernet poe monitor [find]

Property Description
name () Name of an interface
poe-out () Shows PoE-Out settings
poe-out-status () Shows current PoE-Out status on port
  • powered-on - Power is applied to the port, and PoE-Out is operating normally,
  • waiting-for-load - PSE attempts to detect if power can be applied to the port. For power-on to happen there should be resistance on spare pairs in the range from 3kΩ to 26.5kΩ;
  • short-circuit - Short-circuit is detected on PoE-Out port, power is switched off, the only detection with low voltage takes place.
  • overload - The PoE-Out current limit is exceeded, power is switched off on PoE-Out port. For port limits see each model specifications.
  • current-too-low - current-too-low means that PD draws too low current than normal PoE-Out device should, reason for this can be:

Delivered voltage at PD is too low for normal powering;

PD uses second power source which has a higher voltage than PSE, so all current is taken from second DC source, not PSE PoE-Out port;

  • off - all detection and power is turned off for this port;
poe-out-voltage () Displays PoE Voltage which is applied to the PD.
poe-out-current () Displays port current (mA) which is drawn by the PD.
poe-out-power () Displays PD power consumption

If power-cycle-ping feature is used, /interface ethernet poe monitor [find] will show additional fields:

power-cycle-host-alive: <YES/NO> (Shows if monitored host is reachable)
power-cycle-after:<TIME> (Shows time, after which the port will be power-cycled)

SNMP

It is possible to monitor PoE-Out values using SNMP protocol, this requires enabled SNMP on PSE. SNMP Wiki

SNMP OID tables:

  • 1.3.6.1.4.1.14988.1.1.15.1.1.1 - interface id
  • 1.3.6.1.4.1.14988.1.1.15.1.1.2 - interface names
  • 1.3.6.1.4.1.14988.1.1.15.1.1.4 - voltage in dV (decivolt)
  • 1.3.6.1.4.1.14988.1.1.15.1.1.5 - current in mA
  • 1.3.6.1.4.1.14988.1.1.15.1.1.6 - power usage in dW (deviwatt)

SNMP values can be requested also from the RouterOS, for example, snmp-walk will print current mA from all available PoE-Out ports:

/tool snmp-walk address=10.155.149.252 oid=1.3.6.1.4.1.14988.1.1.15.1.1.5

To get very specific OID value, use snmp-get tool (displays current mA on ether3 interface):

tool snmp-get address=10.155.149.252 oid=1.3.6.1.4.1.14988.1.1.15.1.1.5.3

SwOS

A PoE-Out controller will enable certain monitoring features also from SwOS, such as PoE-Out Status, PoE-Out Current, PoE-Out Voltage and PoE-Out Power usage.

All PoE-Out configuration and monitoring is located on one page, under PoE tab http://<IP>/index.html#poe:

SwOS PoE.png


PoE-Out notifications

PoE-Out LEDs

Models with dependant voltage output

PoE-Out LED behaviour can differ between models, but most of them will indicate PoE-Out state on one additional LED. Devices with one voltage output will light:

  • Red colour LED - PoE-Out port state is powered-on (auto or forced-on mode).
  • Blinking Red colour LED - PoE-Out port state is short-circuit

Models with selectable voltage output

Models with multiple voltage options can indicate additional information:

  • Green colour triangle LED - PoE-Out port state is powered-on (auto or forced-on mode), PD uses low voltage.
  • Red colour triangle LED - PoE-Out port state is powered-on (auto or forced-on mode), PD uses high voltage (af/at or passive).
  • Blinking Green colour triangle LED - PoE-Out port state is short-circuit or overload
  • Blinking Red colour triangle LED - PoE-Out port state is short-circuit or overload

Model-specific LED behaviour

  • CRS112-8P-4S - All PoE LEDs flashing: wrong voltage PSU plugged into one of the ports.
  • CRS328-24P-4S+ - indicates an exceeded overall max PoE output limit. Port PoE-Out priorities will work in 3 independent sections (8 ports each) and overload will happen in any section that breach 150W consumption.

PoE-Out Logs

By default PoE-Out event logging is enabled and uses "warning" and "info" topics to notify the user about PoE-Out state changes. Log entries will be added on each PoE-Out state change. Important logs will be added with "warning" topic, informative logs will be added with "info" topic.

To avoid unnecessary logging in cases when PD is not powered because of current-too-low, RouterOS will filter such events, and add one log per every 512 current-too-low events.

Logs can be disabled if necessary:

/system logging set [find topics~"info"] topics=info,!poe-out 
/system logging set [find topics~"warning"] topics=warning,!poe-out 

PoE-Out Warnings in GUI/CLI

To notify a user about important PoE-Out related problems, messages will be shown in Winbox / Webig and CLI interface fields:

     1  RS ;;; poe-out status: overload
       ether1                              ether            1500  1588       9204 64:D1:54:61:D5:E0

Webfig and Winbox will notify user under interfaces:

WebFIG PoE WRN.png


How it works

PoE-Out Modes

auto-on mode

If auto-on is selected on PoE-Out interface, then port operates in this strict order:

  • PSE with low voltage checks for a resistance on the connected port. If detected resistance range is between (3kΩ to 26.5kΩ) power is turned on;
  • When power is applied, the PSE continuously checks if overload limit is not reached or short circuit detected
  • If the cable is unplugged, the port returns in detection state and will remain off until suitable PD is detected

forced-on mode

If forced-on is selected then port operates in this strict order:

  • PSE disables resistance check on the port, and apply power on pins 4,5 (+) and 7,8 (-), even if no cable is attached
  • When power is applied, PSE still continuously checks if an overload or short circuit is not detected
  • After the cable is unplugged, the power still remains enabled on the port.

off mode

If off mode is used, PoE-Out on the port will be turned off, no detection will take place, and interface will behave as a simple Ethernet port.


PoE-Out limitations

It is important to check PoE-Out specification to find out hardware limitations because it can differ between models

PoE-Out port limitation

PoE-Out ports are limited with max amp values which are supported in particular voltage, usually max current will differ for low voltage devices (up to 30 V), and for high voltage devices (31 to 57 V).

PoE-Out total limitation

PSE has also a total PoE-Out current limitation which can't be exceeded, even if individual port limit allows it.

PoE Out polarity

All MikroTik PSE uses the same PoE-Out pin polarity Mode B 4,5 (+) and 7,8 (-), however other vendors can use opposite or Mode A pinout on PD, this would require using a special crossover cable.

Icon-note.png

Note: Passive PD with high input inrush current can result in overcurrent protection on PSE, make sure that PD specification supports powering from PSE (not only from the passive power injector)


Safety

PSE has following safety features:

PoE-Out compatibility detection

The auto-on mode is considered safe, it will check if the resistance on the port is within allowed range and only then enable PoE out on the interface. The range is 3kΩ to 26.5kΩ

Overload protection

When PoE-Out port is powered-on, the port is constantly checked for overload, If that is detected to avoid hardware damage of PD or PSE, the PoE-Out is turned off on this port.

In seconds the PoE Out feature will be turned on again to see if the environment has changed and PD can be supplied with power again. That is important for configurations that are not connected to mains (solar installations, equipment running on batteries due to mains failure) so that when voltage drops - overload will be detected and connected devices turned off. After a while when voltage level returns to usual operating value - connected equipment can be powered up again.

Short circuit detection

When power is enabled on PoE-Out port, PSE continuously checks for a short circuit. If it is detected to ensure that there is no additional damage on PD and PSE, the power is turned off on all ports. PSE will continue to check PoE-Out port until environment returns to normal.

Icon-warn.png

Warning: Make sure that non-standard incompatible PD which does not have the resistance range 3kΩ to 26.5kΩ are not attached, so the PSE would not try to apply power on them


Model-specific features

PSE with independent 8-port sections (CRS112-8P-4S-IN, CRS328-24P-4S+RM) allows PoE-Out to work independantly from the RouterOS, this means that you can reboot/upgrade your RouterOS and the PD will not be rebooted.

PoE Out examples

RouterOS allows to define priorities on PoE-Out ports, so if your installation is going over power budget, the PSE will disable less important PD with the lowest priority.

Priority of 0 is the highest priority, 99 - lowest

Icon-note.png

Note: CRS328-24P-4S+ Poe-Out priorities work independently on each 8 port section!


Setting up priority

Example of how to set priorities from CLI:

 /interface ethernet poe set ether2 poe-priority=10
 /interface ethernet poe set ether3 poe-priority=13
 /interface ethernet poe set ether4 poe-priority=11
 /interface ethernet poe set ether5 poe-priority=14

What will happen when power budget will go over total PoE-Out limit - first, if overload is detected, ether5 will be turned off (lowest priority), then recheck is done and if still total limit overload is detected next port in priority will be turned off, in this example, ether3 will be turned off. Both of these ports will be reached every few seconds to check if it is possible to turn PoE-Out on for these ports. Power up will happen in reverse order as the power was cut.

Same priority

if all, or some ports will have the same poe-priority, then port with the lowest port number will have higher priority

 /interface ethernet poe set ether2 poe-priority=10
 /interface ethernet poe set ether3 poe-priority=10
 /interface ethernet poe set ether4 poe-priority=10
 /interface ethernet poe set ether5 poe-priority=10

In this example, if the total PoE-Out limit is reached ether5 will be turned off first, then ether4 then ether3 as all of these ports have same poe priority.

Monitoring PoE-Out

PoE-Out ports can be monitored using a command /interface ethernet poe monitor <interface>

[admin@MikroTik] > interface ethernet poe monitor [find]
              name: ether2 ether3 ether4 ether5
   poe-out-voltage: 23.2V  23.2V  23.2V  
   poe-out-current: 224mA  116mA  64mA   
     poe-out-power: 5.1W   2.6W   1.4W 


Power-cycle ping

Monitor connected PD with power-cycle-ping feature:

/interface ethernet poe set ether1 power-cycle-ping-enabled=yes power-cycle-ping-address=00:8D:8C:35:54:04 power-cycle-ping-timeout=30s

In this example, PD attached to ether1 will be continuously monitored using a power-cycle-ping feature, which will send arp-ping and wait for a reply. If PD with MAC-Address 00:8D:8C:35:54:04 will not respond for more than 30s, the PoE-Out port will be switched off for 5s.

Troubleshooting

In cases if PD does not power-up or is rebooted from your PSE, it's suggested to first check:

  • PD supported input voltage - PSE output voltage should be in the range which is supported form the PD, otherwise PD is non-compliant with the PSE, and will not be able to power-up check PD datasheet.
  • PD supported input PoE-in standard - Some PD does not support af/at standard even if it has PoE-in support up to 57 V, check PD datasheet.
  • PD is rebooted from PSE
    • Check if PD does not exceed PoE-Out port limit and Total-PoE-Out port limit of the PSE, check PSE datasheet.
    • Check if Voltage limit does not drop bellow supported (Can be caused by voltage drop on the wires).
    • Check if you are using a proper power supply, the output power of PSU should be calculated from:
      (MAX power consumption of PSE) + (MAX power consumption of all PD) + 10%)
    • Check if you are using good quality ethernet cables, it's important especially in cases if PoE is used.
  • Chech RouterOS version - it's possible, that some PoE related features will be updated with RouterOS, make sure that you are running the latest RouterOS version.
  • PD Does not power up
    • There can be case if PD is not powered, even if it support passive PoE, and does not consume more than specified PSE port limit, reason for such case can be too high inrush current which can lead to overcurrent protection on PSE, make sure that PD specification supports powering from PSE (not only from passive power injector)
    • Polarity - Devices with opposite or different pinout can be unable to powerup from all PSE. Check PD datasheet.
    • Incompatible resistance - PD resistance on spare pairs should have range from 3kΩ to 26.5kΩ (For Passive-PoE) and from 23.75kΩ to 26.25kΩ on af/at.


Legacy

PoE-Out Controller upgrade

PoE-Out devices which are running RouterOS 5.x can also hold old PoE-Out controller firmware, upgrade to RouterOS 6.x will automatically update the PoE-Out firmware. Changes between 1.x and 2.x PoE-Out controller firmware will result in higher Max-port limits (0.5A to 1A) in case if it's supported by the hardware, also will provide some additional data which can be monitored, and allow to use PoE-Out priorities.

All MikroTik devices which come with RouterOS 6.x already support the latest PoE-Out firmware.

FAQ